fail2ban: fix package for fail2ban v0.11.2 16554/head
authorKerma Gérald <gandalf@gk2.net>
Tue, 7 Sep 2021 12:55:56 +0000 (14:55 +0200)
committerKerma Gérald <gandalf@gk2.net>
Tue, 7 Sep 2021 13:12:59 +0000 (15:12 +0200)
fail2ban v0.11.2 package version 2

Following PR #15098, add fixes to build fail2ban package:
- remove use of fail2ban-python (directly use python3 in script)
- remove link to python3 in /usr/bin (break the package build)
- remove python-tests (reduce the package size)

Signed-off-by: Kerma Gérald <gandalf@gk2.net>
net/fail2ban/Makefile
net/fail2ban/patches/001-fail2ban-fix-python3-script.patch [new file with mode: 0644]

index 19f8768a18f7abde3ee85291a9a91899378df62b..1988144394cd0d1363ed10ea16cd2a3d567a304f 100644 (file)
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=fail2ban
 PKG_VERSION:=0.11.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/fail2ban/fail2ban/tar.gz/$(PKG_VERSION)?
@@ -46,12 +46,16 @@ define Package/fail2ban/conffiles
 /etc/config/fail2ban
 endef
 
+define Py3Package/fail2ban/filespec
++|$(PYTHON3_PKG_DIR)
+-|$(PYTHON3_PKG_DIR)/fail2ban/tests
+endef
+
 define Py3Package/fail2ban/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/fail2ban-server $(1)/usr/bin/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/fail2ban-client $(1)/usr/bin/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/fail2ban-regex $(1)/usr/bin/
-       $(LN) /usr/bin/python3 $(1)/usr/bin/fail2ban-python
 
        $(INSTALL_DIR) $(1)/etc/config
        $(INSTALL_CONF) ./files/fail2ban.config $(1)/etc/config/fail2ban
diff --git a/net/fail2ban/patches/001-fail2ban-fix-python3-script.patch b/net/fail2ban/patches/001-fail2ban-fix-python3-script.patch
new file mode 100644 (file)
index 0000000..6ff0e41
--- /dev/null
@@ -0,0 +1,8 @@
+--- a/config/filter.d/ignorecommands/apache-fakegooglebot
++++ b/config/filter.d/ignorecommands/apache-fakegooglebot
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env fail2ban-python
++#!/usr/bin/env python3
+ # Inspired by https://isc.sans.edu/forums/diary/When+Google+isnt+Google/15968/
+ #
+ # Written in Python to reuse built-in Python batteries and not depend on