net/mosquitto: add PROVIDES to daemon and library
authorKarl Palsson <karlp@etactica.com>
Tue, 17 Jan 2017 10:43:42 +0000 (10:43 +0000)
committerKarl Palsson <karlp@etactica.com>
Tue, 17 Jan 2017 17:06:42 +0000 (17:06 +0000)
Adding PROVIDES to both the daemon and library and -nossl variants allow
downstream packages to simply declare a single dependency.

mosquitto-client however, still needs to explicitly depend on the ssl or
nossl variant however.

Signed-off-by: Karl Palsson <karlp@etactica.com>
net/mosquitto/Makefile

index 94a0298c15929efda0cd4010326234b9a9c1f96b..c8484fe1970ad750bb1a696b5717127fbab89dcf 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mosquitto
 PKG_VERSION:=1.4.10
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_LICENSE:=BSD-3-Clause
 PKG_LICENSE_FILES:=LICENSE.txt
 
@@ -36,12 +36,14 @@ define Package/$(PKG_NAME)
     TITLE+= (with SSL support)
     DEPENDS+= +libopenssl +MOSQUITTO_LWS:libwebsockets-openssl
     VARIANT:=ssl
+    PROVIDES:=mosquitto
 endef
 
 define Package/$(PKG_NAME)-nossl
     $(call Package/$(PKG_NAME)/default)
     TITLE+= (without SSL support)
     VARIANT:=nossl
+    PROVIDES:=mosquitto
 endef
 
 define Package/$(PKG_NAME)/config
@@ -105,6 +107,7 @@ define Package/libmosquitto/default
     CATEGORY:=Libraries
     DEPENDS:=+libpthread +librt +libcares
     TITLE:= mosquitto - client library
+    PROVIDES:=libmosquitto
 endef
 
 define Package/libmosquitto