gstreamer1: Disable debug + other fixes
authorRosen Penev <rosenp@gmail.com>
Mon, 18 Mar 2019 00:03:02 +0000 (17:03 -0700)
committerRosen Penev <rosenp@gmail.com>
Mon, 18 Mar 2019 03:22:04 +0000 (20:22 -0700)
Disabled a bunch of debug stuff in order to save size.

Also removed the rpath stuff as that has not been needed for a long time.

Added PKG_BUILD_PARALLEL for faster compilation.

Removed two patches that have --disable configure parameters now.

Refreshed patches.

Size of libgstreamer1 from 822243 to 529366 on mvebu.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
multimedia/gstreamer1/Makefile
multimedia/gstreamer1/patches/001-no-translations.patch
multimedia/gstreamer1/patches/002-no-tests.patch [deleted file]
multimedia/gstreamer1/patches/003-no-docs.patch [deleted file]
multimedia/gstreamer1/patches/010-gstplugin-use-lazy-symbol-binding.patch

index 4d1e7e93eee95cc510fcbe64055b16b2d80ba920..2beaf66d759726564c727dae6de87bf10a4cc43a 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gstreamer1
 PKG_VERSION:=1.15.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org> \
                Ted Hess <thess@kitschensync.net>
@@ -25,6 +25,7 @@ PKG_HASH:=27a3211eb5c3f6929c5f123ffecaac0ea6e9ed6b93be879c033a7d5af13ad7e6
 PKG_FIXUP:=autoreconf
 PKG_REMOVE_FILES:=autogen.sh aclocal.m4
 
+PKG_BUILD_PARALLEL:=1
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
@@ -118,13 +119,20 @@ GST_VERSION:=1.0
 
 CONFIGURE_ARGS += \
        --enable-static \
+       --disable-Bsymbolic \
        --disable-benchmarks \
+       --disable-debug \
        --disable-examples \
        --disable-failing-tests \
        --disable-fatal-warnings \
        --disable-introspection \
+       --disable-glib-asserts \
+       --disable-gobject-cast-checks \
        --disable-gst-tracer-hooks \
+       --disable-gst-debug \
        --disable-gtk-doc-html \
+       --disable-option-parsing \
+       --disable-rpath \
        --disable-tests \
        --disable-valgrind \
        --without-dw \
@@ -132,10 +140,6 @@ CONFIGURE_ARGS += \
        --without-libintl-prefix \
        --without-unwind
 
-EXTRA_LDFLAGS+= \
-       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
-       $(if $(ICONV_FULL),-liconv)
-
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include/gstreamer-$(GST_VERSION)
        ( cd $(PKG_INSTALL_DIR); $(CP) \
index ae6cc27d80b782fc2349303a8c76c11732011b3f..e6c686401185cc857ac12b55e192416c996761d2 100644 (file)
@@ -18,7 +18,7 @@
        data
 --- a/configure.ac
 +++ b/configure.ac
-@@ -1086,7 +1086,6 @@ libs/gst/net/Makefile
+@@ -1108,7 +1108,6 @@ libs/gst/net/Makefile
  plugins/Makefile
  plugins/elements/Makefile
  plugins/tracers/Makefile
diff --git a/multimedia/gstreamer1/patches/002-no-tests.patch b/multimedia/gstreamer1/patches/002-no-tests.patch
deleted file mode 100644 (file)
index f3d7115..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -7,7 +7,7 @@ aclocaldir = $(datadir)/aclocal
- aclocal_DATA = gst-element-check-1.0.m4
- SUBDIRS = pkgconfig \
--      gst libs plugins tests \
-+      gst libs plugins \
-       docs \
-       m4 \
-       common \
-@@ -19,7 +19,7 @@ endif
- # These are all the possible subdirs
- DIST_SUBDIRS = pkgconfig \
--      gst libs plugins tools tests \
-+      gst libs plugins tools \
-       docs \
-       m4 \
-       common \
---- a/configure.ac
-+++ b/configure.ac
-@@ -1086,20 +1086,6 @@ libs/gst/net/Makefile
- plugins/Makefile
- plugins/elements/Makefile
- plugins/tracers/Makefile
--tests/Makefile
--tests/benchmarks/Makefile
--tests/check/Makefile
--tests/misc/Makefile
--tests/examples/Makefile
--tests/examples/adapter/Makefile
--tests/examples/controller/Makefile
--tests/examples/stepping/Makefile
--tests/examples/helloworld/Makefile
--tests/examples/memory/Makefile
--tests/examples/netclock/Makefile
--tests/examples/ptp/Makefile
--tests/examples/streamiddemux/Makefile
--tests/examples/streams/Makefile
- tools/Makefile
- common/Makefile
- common/m4/Makefile
diff --git a/multimedia/gstreamer1/patches/003-no-docs.patch b/multimedia/gstreamer1/patches/003-no-docs.patch
deleted file mode 100644 (file)
index b0f0e14..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -8,7 +8,6 @@ aclocal_DATA = gst-element-check-1.0.m4
- SUBDIRS = pkgconfig \
-       gst libs plugins \
--      docs \
-       m4 \
-       common \
-       data
-@@ -20,7 +19,6 @@ endif
- # These are all the possible subdirs
- DIST_SUBDIRS = pkgconfig \
-       gst libs plugins tools \
--      docs \
-       m4 \
-       common \
-       data
---- a/configure.ac
-+++ b/configure.ac
-@@ -1089,12 +1089,6 @@ plugins/tracers/Makefile
- tools/Makefile
- common/Makefile
- common/m4/Makefile
--docs/Makefile
--docs/gst/Makefile
--docs/gst/gstreamer.types
--docs/libs/Makefile
--docs/plugins/Makefile
--docs/version.entities
- m4/Makefile
- pkgconfig/Makefile
- stamp.h
index 976237b82f4f96b08bd92ca8d46938842f4b70a4..ab72a4ffad295662db1371b27de128017614259d 100644 (file)
@@ -1,6 +1,6 @@
 --- a/gst/gstplugin.c
 +++ b/gst/gstplugin.c
-@@ -776,15 +776,8 @@ _priv_gst_plugin_load_file_for_registry (const gchar * filename,
+@@ -777,15 +777,8 @@ _priv_gst_plugin_load_file_for_registry (const gchar * filename,
      goto return_error;
    }