perlmod: fix ability to build module out-of-feed 7089/head
authorPhilip Prindeville <philipp@redfish-solutions.com>
Sun, 23 Sep 2018 19:36:37 +0000 (13:36 -0600)
committerPhilip Prindeville <philipp@redfish-solutions.com>
Sun, 23 Sep 2018 20:19:51 +0000 (14:19 -0600)
Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
lang/perl/Makefile
lang/perl/perlmod.mk

index 86a4351ac3c06d26f548cd6f600f1c2ecd1c8f2a..b92b00279631ae07a0f23b063571d97eb8ed3efc 100644 (file)
@@ -11,7 +11,7 @@ include perlver.mk
 
 PKG_NAME:=perl
 PKG_VERSION:=$(PERL_VERSION)
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_URL:=\
                https://cpan.metacpan.org/src/5.0 \
index d00a8c42ecf4c50b03a4906500139a19b98ab554..8a95099155cf63566d613f617a9bc6e3096edea0 100644 (file)
@@ -1,7 +1,11 @@
 # This makefile simplifies perl module builds.
 #
 
-include ../perl/perlver.mk
+ifeq ($(origin PERL_INCLUDE_DIR),undefined)
+  PERL_INCLUDE_DIR:=$(dir $(lastword $(MAKEFILE_LIST)))
+endif
+
+include $(PERL_INCLUDE_DIR)/perlver.mk
 
 ifneq ($(PKG_NAME),perl)
   PKG_VERSION:=$(PKG_VERSION)+perl$(PERL_VERSION2)