kernel: bump 4.9 to 4.9.170
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 22 Apr 2019 19:54:26 +0000 (21:54 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 23 Apr 2019 11:23:22 +0000 (13:23 +0200)
Refreshed all patches.

Compile-tested on: ar71xx
Runtime-tested on: ar71xx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/pending-4.9/332-arc-add-OWRTDTB-section.patch
target/linux/layerscape/patches-4.9/810-iommu-support-layerscape.patch

index d77dd15f368503fca2887f9590c78e4803ef2e9d..3effa1e13b42be31f5e82c903061107774494fb2 100644 (file)
@@ -2,10 +2,10 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-4.9 = .169
+LINUX_VERSION-4.9 = .170
 LINUX_VERSION-4.14 = .112
 
-LINUX_KERNEL_HASH-4.9.169 = b776636c63a555961cfe9f6f4a315e65ab0ff3376acdb3cf5ad654808ff8d6b0
+LINUX_KERNEL_HASH-4.9.170 = 33887b40fc8e0b71f423bb7afe112a4ae190378145f4a3f3892c563b7e43131d
 LINUX_KERNEL_HASH-4.14.112 = 326101e2cc80a0d7e643074fe9e63f0d6a9c8cf97033f8a07848de373203e472
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 4937e11782f50af99bc4003c6b61f3d99583dc7a..ca89f875946b0c1cbfe58ecccf3664ee00eb6f81 100644 (file)
@@ -38,7 +38,7 @@ Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com>
  ;----------------------------------------------------------------
 --- a/arch/arc/kernel/setup.c
 +++ b/arch/arc/kernel/setup.c
-@@ -436,7 +436,7 @@ ignore_uboot_args:
+@@ -444,7 +444,7 @@ ignore_uboot_args:
  #endif
  
        if (use_embedded_dtb) {
@@ -47,7 +47,7 @@ Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com>
                if (!machine_desc)
                        panic("Embedded DT invalid\n");
        }
-@@ -452,6 +452,8 @@ ignore_uboot_args:
+@@ -460,6 +460,8 @@ ignore_uboot_args:
        }
  }
  
index 4c228b333aef39c9542b1a5e9254062bde052d71..11d5c7b561fb739d97a636ed81a8c90d8738a94a 100644 (file)
@@ -995,7 +995,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  };
  
  struct dmar_atsr_unit {
-@@ -4267,27 +4268,40 @@ static inline void init_iommu_pm_ops(voi
+@@ -4270,27 +4271,40 @@ static inline void init_iommu_pm_ops(voi
  int __init dmar_parse_one_rmrr(struct acpi_dmar_header *header, void *arg)
  {
        struct acpi_dmar_reserved_memory *rmrr;
@@ -1041,7 +1041,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  }
  
  static struct dmar_atsr_unit *dmar_find_atsr(struct acpi_dmar_atsr *atsr)
-@@ -4501,6 +4515,7 @@ static void intel_iommu_free_dmars(void)
+@@ -4504,6 +4518,7 @@ static void intel_iommu_free_dmars(void)
        list_for_each_entry_safe(rmrru, rmrr_n, &dmar_rmrr_units, list) {
                list_del(&rmrru->list);
                dmar_free_dev_scope(&rmrru->devices, &rmrru->devices_cnt);
@@ -1049,7 +1049,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                kfree(rmrru);
        }
  
-@@ -5236,6 +5251,45 @@ static void intel_iommu_remove_device(st
+@@ -5239,6 +5254,45 @@ static void intel_iommu_remove_device(st
        iommu_device_unlink(iommu->iommu_dev, dev);
  }
  
@@ -1095,7 +1095,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  #ifdef CONFIG_INTEL_IOMMU_SVM
  #define MAX_NR_PASID_BITS (20)
  static inline unsigned long intel_iommu_get_pts(struct intel_iommu *iommu)
-@@ -5366,19 +5420,21 @@ struct intel_iommu *intel_svm_device_to_
+@@ -5369,19 +5423,21 @@ struct intel_iommu *intel_svm_device_to_
  #endif /* CONFIG_INTEL_IOMMU_SVM */
  
  static const struct iommu_ops intel_iommu_ops = {