python: added configure args for distutils path detection 1043/head
authorJan Čermák <jan.cermak@nic.cz>
Mon, 16 Mar 2015 09:41:33 +0000 (10:41 +0100)
committerJan Čermák <jan.cermak@nic.cz>
Mon, 16 Mar 2015 09:41:33 +0000 (10:41 +0100)
python-package.mk now defines (extends) CONFIGURE_ARGS that are
adjusting PREFIX and EXEC_PREFIX in distutils.sysconfig during
compilation. These variables are sometimes used by autotools to detect
path to Python header files. Adding these variables to python-package.mk
fixes compilation of legacy autotools-configured packages that already
include python-package.mk and do not overwrite CONFIGURE_ARGS.

Signed-off-by: Jan Čermák <jan.cermak@nic.cz>
Cc: Alexandru Ardelean <ardeleanalex@gmail.com>
lang/python/files/python-package.mk

index 6936a0748bd2953d968b05bae7002c87a2fca170..4895b91a1748d8ad7f60918e490364bf4354fb72 100644 (file)
@@ -33,6 +33,13 @@ define HostPython
        )
 endef
 
+# These configure args are needed in detection of path to Python header files
+# using autotools.
+CONFIGURE_ARGS += \
+       _python_sysroot="$(STAGING_DIR)" \
+       _python_prefix="/usr" \
+       _python_exec_prefix="/usr"
+
 PKG_USE_MIPS16:=0
 # This is required in addition to PKG_USE_MIPS16:=0 because otherwise MIPS16
 # flags are inherited from the Python base package (via sysconfig module)