samplicator: update to latest master commit 2021-10-11
authorNick Hainke <vincent@systemli.org>
Sun, 9 Oct 2022 13:29:01 +0000 (15:29 +0200)
committerNick Hainke <vincent@systemli.org>
Thu, 27 Oct 2022 13:18:59 +0000 (15:18 +0200)
The newest master branch has important fixes. However, no new release is
published [0]. Switch to git and update to latest master commit.
This introduces new version scheme by using YYYY-MM-DD of the commit.

In addition, add necessary "PKG_FIXUP" and "PKG_REMOVE_FILES" to allow
compile the new version. Also add enable "PKG_BUILD_PARALLEL".

Further, use a pidfile and remove outdated patches.

https://github.com/sleinen/samplicator/issues/73

Signed-off-by: Nick Hainke <vincent@systemli.org>
net/samplicator/Makefile
net/samplicator/files/samplicator.init
net/samplicator/patches/010-format.patch [deleted file]

index 882e2733bcb9ce2d90c38601c95280e5ca568366..667d595d4bd6a9595948addb853b278615000ec0 100644 (file)
@@ -1,17 +1,22 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=samplicator
-PKG_VERSION:=1.3.6
 PKG_RELEASE:=$(AUTORELEASE)
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://github.com/sleinen/samplicator/releases/download/v$(PKG_VERSION)
-PKG_HASH:=3c4358b4b0992a77251f2b9e2221d4ae945781160732c73504eb126e69d72d40
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://github.com/sleinen/samplicator.git
+PKG_SOURCE_DATE:=2021-10-11
+PKG_SOURCE_VERSION:=ceeb1d280188c155b71d819282490be86190f6f6
+PKG_MIRROR_HASH:=e96ac711313d3554d53ca8de5061b8fb18dfeb2823c4c0fe3404ba3b71e8b689
 
 PKG_MAINTAINER:=Nick Hainke <vincent@systemli.org>
 PKG_LICENSE:=GPL-2.0-only
 PKG_LICENSE_FILES:=COPYING
 
+PKG_FIXUP:=autoreconf
+PKG_REMOVE_FILES:=autogen.sh
+PKG_BUILD_PARALLEL:=1
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/samplicator
index f0e8f42780b6078b233327fe0d716a207d4b331a..0766d397f4cc9fb46429e92d3f62179a2c6f253c 100644 (file)
@@ -5,11 +5,12 @@ START=70
 
 SAMPLICATOR_BIN="/usr/sbin/samplicate"
 SAMPLICATOR_CONF="/etc/samplicator.conf"
+PIDFILE="/var/run/samplicator.pid"
 
 start_service() {
     mkdir -p /var/run
     procd_open_instance
-    procd_set_param command $SAMPLICATOR_BIN -c $SAMPLICATOR_CONF
+    procd_set_param command $SAMPLICATOR_BIN -c $SAMPLICATOR_CONF -m $PIDFILE
     procd_set_param file "$SAMPLICATOR_CONF"
     procd_set_param stdout 1
     procd_set_param stderr 1
diff --git a/net/samplicator/patches/010-format.patch b/net/samplicator/patches/010-format.patch
deleted file mode 100644 (file)
index 9ce8bd8..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/samplicate.c
-+++ b/samplicate.c
-@@ -560,7 +560,7 @@ samplicate (ctx)
-       }
-       if (len != sizeof remote_address)
-       {
--        fprintf (stderr, "recvfrom() return address length %d - expected %d\n",
-+        fprintf (stderr, "recvfrom() return address length %d - expected %zu\n",
-                  len, sizeof remote_address);
-         exit (1);
-       }