bump bemused revision
authorTravis Kemen <thepeople@openwrt.org>
Fri, 9 May 2008 17:09:39 +0000 (17:09 +0000)
committerTravis Kemen <thepeople@openwrt.org>
Fri, 9 May 2008 17:09:39 +0000 (17:09 +0000)
SVN-Revision: 11098

utils/bemused/Makefile
utils/bemused/patches/100-iconv.patch

index bcae09211a39995ff8a9a7ca8f9766f5151f2d51..6dbe4d936d431cb9661dbf31da00a268350cfd27 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bemused-mpd
-PKG_VERSION:=r059
+PKG_VERSION:=r060
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://download.origo.ethz.ch/bemused-lnx-mpdhack/512
-PKG_MD5SUM:=76cb208842cce784fd65ec4d392fd6cb
+PKG_SOURCE_URL:=http://download.origo.ethz.ch/bemused-lnx-mpdhack/513
+PKG_MD5SUM:=08238fef7b00dec19c93d5aa481803c6
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
index 3f60494c331377ae6859a4a5e6e77222bad26c7c..ea97ff5ae950f0dc74dbbe28ee7cd448872b9fa3 100644 (file)
      if (iconv_value == (size_t) -1) {
          error ("ICONV ERROR3: failed to convert string, error: %d\n", errno);
        return "ICONV ERROR3";
---- bemused-mpd-r059/mpdctrl.orig      2008-04-23 11:53:58.000000000 +0200
-+++ bemused-mpd-r059/mpdctrl.c 2008-04-23 14:36:34.000000000 +0200
-@@ -160,8 +160,8 @@
-     }
-     /* OpenWRT needs a type cast */
--    /* iconv_value = iconv(i, (const char **)&p1, &fromlen, &p2, &tolen); */
--    iconv_value = iconv(i, &p1, &fromlen, &p2, &tolen);
-+    iconv_value = iconv(i, (const char **)&p1, &fromlen, &p2, &tolen);
-+    /* iconv_value = iconv(i, &p1, &fromlen, &p2, &tolen); */
-     if (iconv_value == (size_t) -1) {
-         error ("ICONV ERROR3: failed to convert string, error: %d\n", errno);
-       return "ICONV ERROR3";