[python]: fix sqlite extension (#12239)
authorStephen Walker <stephendwalker@gmail.com>
Wed, 24 Oct 2012 00:03:13 +0000 (00:03 +0000)
committerStephen Walker <stephendwalker@gmail.com>
Wed, 24 Oct 2012 00:03:13 +0000 (00:03 +0000)
SVN-Revision: 33902

lang/python/Makefile
lang/python/patches/150-no-sqlite-rpath.patch [new file with mode: 0644]

index e17740f68d898ecfbc9870d689a9d90d35d72716..d66f14c02cc610ca40ebb778c9e205f56022bb72 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python
 PKG_VERSION:=2.7.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://www.python.org/ftp/python/$(PKG_VERSION)
diff --git a/lang/python/patches/150-no-sqlite-rpath.patch b/lang/python/patches/150-no-sqlite-rpath.patch
new file mode 100644 (file)
index 0000000..4f0ec41
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/setup.py
++++ b/setup.py
+@@ -1021,7 +1021,6 @@ class PyBuildExt(build_ext):
+                                   include_dirs=["Modules/_sqlite",
+                                                 sqlite_incdir],
+                                   library_dirs=sqlite_libdir,
+-                                  runtime_library_dirs=sqlite_libdir,
+                                   extra_link_args=sqlite_extra_link_args,
+                                   libraries=["sqlite3",]))
+         else: