oprofile: remove the kernel module package
authorFelix Fietkau <nbd@openwrt.org>
Thu, 24 Feb 2011 01:13:45 +0000 (01:13 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 24 Feb 2011 01:13:45 +0000 (01:13 +0000)
SVN-Revision: 25692

devel/oprofile/Makefile

index 2961e2dfc5cdd54c30d0881a9b90e8086a2fb0eb..d8de5425aa395e8d48953e33cf5546c84389c584 100644 (file)
@@ -22,18 +22,6 @@ PKG_INSTALL:=1
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/kernel.mk
 
-define KernelPackage/oprofile
-  SUBMENU:=Other modules
-  TITLE:=OProfile profiling support
-  KCONFIG:=CONFIG_OPROFILE @!LINUX_2_4
-  FILES:=$(LINUX_DIR)/arch/$(LINUX_KARCH)/oprofile/oprofile.$(LINUX_KMOD_SUFFIX)
-  DEPENDS:=@KERNEL_PROFILING
-endef
-
-define KernelPackage/oprofile/description
-  Kernel module for support for oprofile system profiling.
-endef
-
 define Package/oprofile
   SECTION:=devel
   CATEGORY:=Development
@@ -97,4 +85,3 @@ endef
 
 $(eval $(call BuildPackage,oprofile))
 $(eval $(call BuildPackage,oprofile-utils))
-$(eval $(call KernelPackage,oprofile))