[package] add bash-completion (#4228)
authorFlorian Fainelli <florian@openwrt.org>
Sun, 1 Feb 2009 18:40:04 +0000 (18:40 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 1 Feb 2009 18:40:04 +0000 (18:40 +0000)
SVN-Revision: 14346

utils/bash-completion/Makefile [new file with mode: 0644]

diff --git a/utils/bash-completion/Makefile b/utils/bash-completion/Makefile
new file mode 100644 (file)
index 0000000..62c092d
--- /dev/null
@@ -0,0 +1,49 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=bash-completion
+PKG_VERSION:=20080705
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://ftp.de.debian.org/debian/pool/main/b/bash-completion/
+PKG_MD5SUM:=8bc36281bb0567bc67a9083c4c5595a9
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/bash-completion
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=bash completion scripts
+  DEPENDS:=+libncurses +bash
+  URL:=http://www.caliban.org/bash/
+endef
+
+define Package/bash-completion/description
+  bash completion extends bashs standard completion behavior
+  to achieve complex command lines with just a few keystrokes.
+endef
+
+
+define Build/Configure
+endef
+
+
+define Build/Compile
+endef
+
+define Package/bash-completion/install
+       $(INSTALL_DIR) $(1)/etc/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/bash_completion $(1)/etc
+endef
+
+$(eval $(call BuildPackage,bash-completion))