libgpg-error: copy gpg-error.pc to staging directory 19932/head
authorW. Michael Petullo <mike@flyn.org>
Fri, 18 Nov 2022 02:40:35 +0000 (20:40 -0600)
committerW. Michael Petullo <mike@flyn.org>
Fri, 18 Nov 2022 14:04:05 +0000 (08:04 -0600)
Packages like libassuan and libksba would not compile after updating
libgpg-error to 1.46. This was because gpg-error.m4 (and thus the affected
packages' configure scripts) relies on gpgrt-config, which in turn needs
access to gpg-error.pc. This modifies the libgpg-error build process to
copy gpg-error.pc to OpenWrt's staging directory, so that it is available
for subsequent dependent package builds.

Fixes: https://github.com/openwrt/packages/issues/19880
Signed-off-by: W. Michael Petullo <mike@flyn.org>
libs/libgpg-error/Makefile

index 0f02663202d62e09165d20b928f963d962193c03..77182fa5dfafe12b3ff30342abadd5841472105b 100644 (file)
@@ -91,6 +91,11 @@ define Build/InstallDev
        $(INSTALL_DATA) \
                $(PKG_INSTALL_DIR)/usr/share/aclocal/gpgrt.m4 \
                $(1)/usr/share/aclocal/
+
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/gpg-error.pc \
+               $(1)/usr/lib/pkgconfig
 endef
 
 define Package/libgpg-error/install