tools: Use exported quiet flag from top-level Makefile
authordp-arm <dimitris.papastamos@arm.com>
Tue, 2 May 2017 10:14:29 +0000 (11:14 +0100)
committerDimitris Papastamos <dimitris.papastamos@arm.com>
Mon, 12 Jun 2017 08:54:08 +0000 (09:54 +0100)
When V is set from the command line, the value is passed to the tools'
Makefiles as well.

Change-Id: I91a1f66de5c1ae6f36b6c9f0a9bd550d4a30f092
Signed-off-by: dp-arm <dimitris.papastamos@arm.com>
tools/cert_create/Makefile
tools/fiptool/Makefile

index efd1f25d5833f298a9c5c776504f6be7ecd01456..eae76dfb17e6d643e8033913587e690527313b4b 100644 (file)
@@ -6,7 +6,7 @@
 
 PROJECT                := cert_create
 PLAT           := none
-V              := 0
+V              ?= 0
 DEBUG          := 0
 BINARY         := ${PROJECT}${BIN_EXT}
 OPENSSL_DIR    := /usr
@@ -50,9 +50,9 @@ else
   CFLAGS += -O2 -DLOG_LEVEL=20
 endif
 ifeq (${V},0)
-       Q := @
+  Q := @
 else
-       Q :=
+  Q :=
 endif
 
 $(eval $(call add_define,USE_TBBR_DEFS))
index ee674b7f9f6660e30b4c5c2b0d9163f77e9d2a7a..5e2ecc13f73c68405a2bcf339f0eec6f09989973 100644 (file)
@@ -10,7 +10,7 @@ include ${MAKE_HELPERS_DIRECTORY}build_env.mk
 
 PROJECT := fiptool${BIN_EXT}
 OBJECTS := fiptool.o tbbr_config.o
-V := 0
+V ?= 0
 
 override CPPFLAGS += -D_GNU_SOURCE -D_XOPEN_SOURCE=700
 CFLAGS := -Wall -Werror -pedantic -std=c99