tinycdb: use OpenWrt flags
authorSebastian Kemper <sebastian_ml@gmx.net>
Sun, 15 Dec 2019 09:39:00 +0000 (10:39 +0100)
committerSebastian Kemper <sebastian_ml@gmx.net>
Sun, 15 Dec 2019 09:39:02 +0000 (10:39 +0100)
Currently tinycdb doesn't use {C,CPP,LD}FLAGS. This commit adds
MAKE_FLAGS to address this.

Before:

make[3]: Entering directory '/home/sk/tmp/openwrt/build_dir/target-mips_24kc_musl/tinycdb-0.78'
ccache_cc -O -D_FILE_OFFSET_BITS=64 -c cdb_init.c
cc1: note: someone does not honour COPTS correctly, passed 0 times
ccache_cc -O -D_FILE_OFFSET_BITS=64 -c cdb_find.c
...

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
libs/tinycdb/Makefile

index c633c62ab9e9eb063df9ed96504fcb6166a2cdf2..067844d54b333d3b521bd6ba69df8e0ff5291c54 100644 (file)
@@ -19,6 +19,14 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 
 include $(INCLUDE_DIR)/package.mk
 
+# Pass CPPFLAGS in the CFLAGS as otherwise the build system will
+# ignore them.
+TARGET_CFLAGS+=$(TARGET_CPPFLAGS)
+
+MAKE_FLAGS+= \
+       CFLAGS="$(TARGET_CFLAGS)" \
+       LDFLAGS="$(TARGET_LDFLAGS)"
+
 define Package/tinycdb
   SECTION:=libs
   CATEGORY:=Libraries