sane-backends: select all backends when CONFIG_ALL 1885/head
authorLuiz Angelo Daros de Luca <luizluca@gmail.com>
Thu, 15 Oct 2015 03:35:49 +0000 (00:35 -0300)
committerLuiz Angelo Daros de Luca <luizluca@gmail.com>
Mon, 26 Oct 2015 16:17:28 +0000 (14:17 -0200)
sane-xxx backend packages are hidden packages with custom
config and CONFIG_ALL does not select them alone. Now
sane-backends depends on +ALL:sane-backends-all.

No existing ipk is affected as the changed package/sane-backends
does not exist as an ipk.

030-musl.patch was updated to be submitted upstream. However,
the added preprocessor #if are always true for OpenWRT and will
not change the resulting code.

Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
utils/sane-backends/Makefile
utils/sane-backends/patches/030-musl.patch

index 7c79db0accda3baca53d5a0501c08d106fbf1085..ffed673b027ca0ea1a93695cd3f827b4a813e95b 100644 (file)
@@ -41,6 +41,7 @@ $(call Package/sane-backends/Default)
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE+= (drivers)
+  DEPENDS:=+ALL:sane-backends-all
 endef
 
 define Package/sane-backends/description
index b8dd50ee682e882f2a8dc08d2ca854aaa19a07e7..7f0a5a27820e7848093eb11eeb88ad1bd2560d92 100644 (file)
@@ -1,61 +1,73 @@
 --- a/include/sane/sanei_udp.h
 +++ b/include/sane/sanei_udp.h
-@@ -27,6 +27,7 @@
+@@ -27,6 +27,9 @@
  #include <netinet/in.h>
  #include <netdb.h>
  #endif
++#ifdef HAVE_SYS_TYPES_H
 +#include <sys/types.h>
++#endif
  
  extern SANE_Status sanei_udp_open(const char *host, int port, int *fdp);
  extern SANE_Status sanei_udp_open_broadcast(int *fdp);
 --- a/backend/kvs20xx_cmd.h
 +++ b/backend/kvs20xx_cmd.h
-@@ -9,6 +9,8 @@
+@@ -9,6 +9,10 @@
     Panasonic KV-S20xx USB-SCSI scanners.
  */
  
++#ifdef HAVE_SYS_TYPES_H
 +#include <sys/types.h>
++#endif
 +
  #define COMMAND_BLOCK 1
  #define DATA_BLOCK    2
  #define RESPONSE_BLOCK        3
 --- a/backend/kvs40xx.h
 +++ b/backend/kvs40xx.h
-@@ -10,6 +10,7 @@
+@@ -10,6 +10,9 @@
  
  #include "../include/sane/config.h"
  #include <semaphore.h>
++#ifdef HAVE_SYS_TYPES_H
 +#include <sys/types.h>
++#endif
  
  #undef  BACKEND_NAME
  #define BACKEND_NAME kvs40xx
 --- a/backend/hp5400.c
 +++ b/backend/hp5400.c
-@@ -67,6 +67,7 @@
+@@ -67,6 +67,9 @@
  #include <stdlib.h>           /* malloc, free */
  #include <string.h>           /* memcpy */
  #include <stdio.h>
++#ifdef HAVE_SYS_TYPES_H
 +#include <sys/types.h>
++#endif
  
  
  #define HP5400_CONFIG_FILE "hp5400.conf"
 --- a/backend/hp5590.c
 +++ b/backend/hp5590.c
-@@ -48,6 +48,7 @@
+@@ -48,6 +48,9 @@
  #include <stdio.h>
  #include <string.h>
  #include <unistd.h>
++#ifdef HAVE_SYS_TYPES_H
 +#include <sys/types.h>
++#endif
  
  #include "../include/sane/sane.h"
  #define BACKEND_NAME hp5590
 --- a/backend/epsonds-io.c
 +++ b/backend/epsonds-io.c
-@@ -16,6 +16,7 @@
+@@ -16,6 +16,9 @@
  #include "sane/config.h"
  #include <ctype.h>
  #include <unistd.h>     /* sleep */
++#ifdef HAVE_SYS_TYPES_H
 +#include <sys/types.h>
++#endif
  
  #include "epsonds.h"
  #include "epsonds-io.h"