libx264: fix build on soft-float targets
authorDaniel Golle <daniel@makrotopia.org>
Thu, 22 Sep 2016 22:23:24 +0000 (00:23 +0200)
committerDaniel Golle <daniel@makrotopia.org>
Thu, 22 Sep 2016 22:31:23 +0000 (00:31 +0200)
--disable-asm isn't enough to disable building assembly code on ARM.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
libs/libx264/Makefile

index 4dc9fec36f7e7281286aa9d57310c94a56ad1c31..7054a407108bebed0fa7c383438cb5ffe8f17d0c 100644 (file)
@@ -38,15 +38,17 @@ else
 endif
 endif
 
+ifneq ($(CONFIG_SOFT_FLOAT),)
+CONFIGURE_VARS+= AS= 
+MAKE_FLAGS+= AS= 
+CONFIGURE_ARGS += --disable-asm
+endif
+
 CONFIGURE_ARGS += \
                --enable-shared \
                --enable-pic \
                --disable-cli 
 
-ifeq ($(CONFIG_SOFT_FLOAT),y)
-CONFIGURE_ARGS += --disable-asm
-endif
-
 define Package/libx264
   SECTION:=libs
   CATEGORY:=Libraries