kernel: mtd: backport SafeLoader parser
authorRafał Miłecki <rafal@milecki.pl>
Tue, 18 Oct 2022 20:37:46 +0000 (22:37 +0200)
committerRafał Miłecki <rafal@milecki.pl>
Wed, 2 Nov 2022 07:31:52 +0000 (08:31 +0100)
Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
(cherry picked from commit 711f1a8bcbdde1ee9e2934d707fb1765fc644268)

target/linux/ath79/config-5.4
target/linux/ath79/patches-5.4/404-mtd-cybertan-trx-parser.patch
target/linux/bcm53xx/config-5.4
target/linux/generic/backport-5.4/420-v6.2-mtd-parsers-add-TP-Link-SafeLoader-partitions-table-.patch [new file with mode: 0644]
target/linux/generic/pending-5.4/435-mtd-add-routerbootpart-parser-config.patch
target/linux/ipq806x/patches-5.4/0031-mtd-add-SMEM-parser-for-QCOM-platforms.patch
target/linux/ramips/mt7620/config-5.4
target/linux/ramips/mt7621/config-5.4
target/linux/ramips/mt76x8/config-5.4

index 60f57692e2effc9af61b25a6b402d35cca9932fd..e47398ce2b42cc3aa71136bf5a5fd1f13c85373c 100644 (file)
@@ -175,6 +175,7 @@ CONFIG_MTD_CMDLINE_PARTS=y
 # CONFIG_MTD_MAP_BANK_WIDTH_4 is not set
 # CONFIG_MTD_NAND_RB91X is not set
 CONFIG_MTD_PARSER_CYBERTAN=y
+# CONFIG_MTD_PARSER_TPLINK_SAFELOADER is not set
 CONFIG_MTD_PHYSMAP=y
 CONFIG_MTD_SPI_NOR=y
 CONFIG_MTD_SPLIT_ELF_FW=y
index 923589661ee04940ec18b7e302d72036b69893aa..540e134ef05f205fafcdcc7454422658e32c96ca 100644 (file)
@@ -7,7 +7,7 @@
 +obj-$(CONFIG_MTD_PARSER_CYBERTAN)     += parser_cybertan.o
  obj-$(CONFIG_MTD_PARSER_IMAGETAG)     += parser_imagetag.o
  obj-$(CONFIG_MTD_AFS_PARTS)           += afs.o
- obj-$(CONFIG_MTD_PARSER_TRX)          += parser_trx.o
+ obj-$(CONFIG_MTD_PARSER_TPLINK_SAFELOADER)    += tplink_safeloader.o
 --- a/drivers/mtd/parsers/Kconfig
 +++ b/drivers/mtd/parsers/Kconfig
 @@ -102,6 +102,14 @@ config MTD_OF_PARTS_LINKSYS_NS
index bee678bcf4fb4260e6ddaae4785e26543db2028d..abfd693f3919d43ef53d20aaf5909f489f07e109 100644 (file)
@@ -260,6 +260,7 @@ CONFIG_MTD_NAND_BRCMNAND=y
 CONFIG_MTD_NAND_CORE=y
 CONFIG_MTD_NAND_ECC_SW_HAMMING=y
 CONFIG_MTD_OF_PARTS_LINKSYS_NS=y
+CONFIG_MTD_PARSER_TPLINK_SAFELOADER=y
 CONFIG_MTD_PARSER_TRX=y
 CONFIG_MTD_RAW_NAND=y
 CONFIG_MTD_SPI_NOR=y
diff --git a/target/linux/generic/backport-5.4/420-v6.2-mtd-parsers-add-TP-Link-SafeLoader-partitions-table-.patch b/target/linux/generic/backport-5.4/420-v6.2-mtd-parsers-add-TP-Link-SafeLoader-partitions-table-.patch
new file mode 100644 (file)
index 0000000..898a9bf
--- /dev/null
@@ -0,0 +1,229 @@
+From aec4d5f5ffd0f0092bd9dc21ea90e0bc237d4b74 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <rafal@milecki.pl>
+Date: Sat, 15 Oct 2022 11:29:50 +0200
+Subject: [PATCH] mtd: parsers: add TP-Link SafeLoader partitions table parser
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+This parser deals with most TP-Link home routers. It reads info about
+partitions and registers them in the MTD subsystem.
+
+Example from TP-Link Archer C5 V2:
+
+spi-nor spi0.0: s25fl128s1 (16384 Kbytes)
+15 tplink-safeloader partitions found on MTD device spi0.0
+Creating 15 MTD partitions on "spi0.0":
+0x000000000000-0x000000040000 : "fs-uboot"
+0x000000040000-0x000000440000 : "os-image"
+0x000000440000-0x000000e40000 : "rootfs"
+0x000000e40000-0x000000e40200 : "default-mac"
+0x000000e40200-0x000000e40400 : "pin"
+0x000000e40400-0x000000e40600 : "product-info"
+0x000000e50000-0x000000e60000 : "partition-table"
+0x000000e60000-0x000000e60200 : "soft-version"
+0x000000e61000-0x000000e70000 : "support-list"
+0x000000e70000-0x000000e80000 : "profile"
+0x000000e80000-0x000000e90000 : "default-config"
+0x000000e90000-0x000000ee0000 : "user-config"
+0x000000ee0000-0x000000fe0000 : "log"
+0x000000fe0000-0x000000ff0000 : "radio_bk"
+0x000000ff0000-0x000001000000 : "radio"
+
+Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
+Signed-off-by: Miquel Raynal <miquel.raynal@bootlin.com>
+Link: https://lore.kernel.org/linux-mtd/20221015092950.27467-2-zajec5@gmail.com
+---
+ drivers/mtd/parsers/Kconfig             |  15 +++
+ drivers/mtd/parsers/Makefile            |   1 +
+ drivers/mtd/parsers/tplink_safeloader.c | 150 ++++++++++++++++++++++++
+ 3 files changed, 166 insertions(+)
+ create mode 100644 drivers/mtd/parsers/tplink_safeloader.c
+
+--- a/drivers/mtd/parsers/Kconfig
++++ b/drivers/mtd/parsers/Kconfig
+@@ -113,6 +113,21 @@ config MTD_AFS_PARTS
+         for your particular device. It won't happen automatically. The
+         'physmap' map driver (CONFIG_MTD_PHYSMAP) does this, for example.
++config MTD_PARSER_TPLINK_SAFELOADER
++      tristate "TP-Link Safeloader partitions parser"
++      depends on MTD && (ARCH_BCM_5301X || ATH79 || SOC_MT7620 || SOC_MT7621 || COMPILE_TEST)
++      help
++        TP-Link home routers use flash partitions to store various data. Info
++        about flash space layout is stored in a partitions table using a
++        custom ASCII-based format.
++
++        That format was first found in devices with SafeLoader bootloader and
++        was named after it. Later it was adapted to CFE and U-Boot
++        bootloaders.
++
++        This driver reads partitions table, parses it and creates MTD
++        partitions.
++
+ config MTD_PARSER_TRX
+       tristate "Parser for TRX format partitions"
+       depends on MTD && (BCM47XX || ARCH_BCM_5301X || COMPILE_TEST)
+--- a/drivers/mtd/parsers/Makefile
++++ b/drivers/mtd/parsers/Makefile
+@@ -9,6 +9,7 @@ ofpart-$(CONFIG_MTD_OF_PARTS_BCM4908)  +=
+ ofpart-$(CONFIG_MTD_OF_PARTS_LINKSYS_NS)+= ofpart_linksys_ns.o
+ obj-$(CONFIG_MTD_PARSER_IMAGETAG)     += parser_imagetag.o
+ obj-$(CONFIG_MTD_AFS_PARTS)           += afs.o
++obj-$(CONFIG_MTD_PARSER_TPLINK_SAFELOADER)    += tplink_safeloader.o
+ obj-$(CONFIG_MTD_PARSER_TRX)          += parser_trx.o
+ obj-$(CONFIG_MTD_SHARPSL_PARTS)               += sharpslpart.o
+ obj-$(CONFIG_MTD_REDBOOT_PARTS)               += redboot.o
+--- /dev/null
++++ b/drivers/mtd/parsers/tplink_safeloader.c
+@@ -0,0 +1,150 @@
++// SPDX-License-Identifier: GPL-2.0-only
++/*
++ * Copyright © 2022 Rafał Miłecki <rafal@milecki.pl>
++ */
++
++#include <linux/kernel.h>
++#include <linux/module.h>
++#include <linux/mtd/mtd.h>
++#include <linux/mtd/partitions.h>
++#include <linux/of.h>
++#include <linux/slab.h>
++
++#define TPLINK_SAFELOADER_DATA_OFFSET         4
++#define TPLINK_SAFELOADER_MAX_PARTS           32
++
++struct safeloader_cmn_header {
++      __be32 size;
++      uint32_t unused;
++} __packed;
++
++static void *mtd_parser_tplink_safeloader_read_table(struct mtd_info *mtd)
++{
++      struct safeloader_cmn_header hdr;
++      struct device_node *np;
++      size_t bytes_read;
++      size_t offset;
++      size_t size;
++      char *buf;
++      int err;
++
++      np = mtd_get_of_node(mtd);
++      if (mtd_is_partition(mtd))
++              of_node_get(np);
++      else
++              np = of_get_child_by_name(np, "partitions");
++
++      if (of_property_read_u32(np, "partitions-table-offset", (u32 *)&offset)) {
++              pr_err("Failed to get partitions table offset\n");
++              goto err_put;
++      }
++
++      err = mtd_read(mtd, offset, sizeof(hdr), &bytes_read, (uint8_t *)&hdr);
++      if (err && !mtd_is_bitflip(err)) {
++              pr_err("Failed to read from %s at 0x%zx\n", mtd->name, offset);
++              goto err_put;
++      }
++
++      size = be32_to_cpu(hdr.size);
++
++      buf = kmalloc(size + 1, GFP_KERNEL);
++      if (!buf)
++              goto err_put;
++
++      err = mtd_read(mtd, offset + sizeof(hdr), size, &bytes_read, buf);
++      if (err && !mtd_is_bitflip(err)) {
++              pr_err("Failed to read from %s at 0x%zx\n", mtd->name, offset + sizeof(hdr));
++              goto err_kfree;
++      }
++
++      buf[size] = '\0';
++
++      of_node_put(np);
++
++      return buf;
++
++err_kfree:
++      kfree(buf);
++err_put:
++      of_node_put(np);
++      return NULL;
++}
++
++static int mtd_parser_tplink_safeloader_parse(struct mtd_info *mtd,
++                                            const struct mtd_partition **pparts,
++                                            struct mtd_part_parser_data *data)
++{
++      struct mtd_partition *parts;
++      char name[65];
++      size_t offset;
++      size_t bytes;
++      char *buf;
++      int idx;
++      int err;
++
++      parts = kcalloc(TPLINK_SAFELOADER_MAX_PARTS, sizeof(*parts), GFP_KERNEL);
++      if (!parts) {
++              err = -ENOMEM;
++              goto err_out;
++      }
++
++      buf = mtd_parser_tplink_safeloader_read_table(mtd);
++      if (!buf) {
++              err = -ENOENT;
++              goto err_out;
++      }
++
++      for (idx = 0, offset = TPLINK_SAFELOADER_DATA_OFFSET;
++           idx < TPLINK_SAFELOADER_MAX_PARTS &&
++           sscanf(buf + offset, "partition %64s base 0x%llx size 0x%llx%zn\n",
++                  name, &parts[idx].offset, &parts[idx].size, &bytes) == 3;
++           idx++, offset += bytes + 1) {
++              parts[idx].name = kstrdup(name, GFP_KERNEL);
++              if (!parts[idx].name) {
++                      err = -ENOMEM;
++                      goto err_free;
++              }
++      }
++
++      if (idx == TPLINK_SAFELOADER_MAX_PARTS)
++              pr_warn("Reached maximum number of partitions!\n");
++
++      kfree(buf);
++
++      *pparts = parts;
++
++      return idx;
++
++err_free:
++      for (idx -= 1; idx >= 0; idx--)
++              kfree(parts[idx].name);
++err_out:
++      return err;
++};
++
++static void mtd_parser_tplink_safeloader_cleanup(const struct mtd_partition *pparts,
++                                               int nr_parts)
++{
++      int i;
++
++      for (i = 0; i < nr_parts; i++)
++              kfree(pparts[i].name);
++
++      kfree(pparts);
++}
++
++static const struct of_device_id mtd_parser_tplink_safeloader_of_match_table[] = {
++      { .compatible = "tplink,safeloader-partitions" },
++      {},
++};
++MODULE_DEVICE_TABLE(of, mtd_parser_tplink_safeloader_of_match_table);
++
++static struct mtd_part_parser mtd_parser_tplink_safeloader = {
++      .parse_fn = mtd_parser_tplink_safeloader_parse,
++      .cleanup = mtd_parser_tplink_safeloader_cleanup,
++      .name = "tplink-safeloader",
++      .of_match_table = mtd_parser_tplink_safeloader_of_match_table,
++};
++module_mtd_part_parser(mtd_parser_tplink_safeloader);
++
++MODULE_LICENSE("GPL");
index ab1e09a5f129d991b87e75fea8a2750becb8d987..8705a38f848c0a61070356447d13e17cb83a3eee 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: Thibaut VARÈNE <hacks@slashdirt.org>
 
 --- a/drivers/mtd/parsers/Kconfig
 +++ b/drivers/mtd/parsers/Kconfig
-@@ -195,3 +195,12 @@ config MTD_REDBOOT_PARTS_READONLY
+@@ -210,3 +210,12 @@ config MTD_REDBOOT_PARTS_READONLY
          'FIS directory' images, enable this option.
  
  endif # MTD_REDBOOT_PARTS
@@ -31,7 +31,7 @@ Signed-off-by: Thibaut VARÈNE <hacks@slashdirt.org>
 +       formatted DTS.
 --- a/drivers/mtd/parsers/Makefile
 +++ b/drivers/mtd/parsers/Makefile
-@@ -13,3 +13,4 @@ obj-$(CONFIG_MTD_AFS_PARTS)          += afs.o
+@@ -14,3 +14,4 @@ obj-$(CONFIG_MTD_PARSER_TPLINK_SAFELOADE
  obj-$(CONFIG_MTD_PARSER_TRX)          += parser_trx.o
  obj-$(CONFIG_MTD_SHARPSL_PARTS)               += sharpslpart.o
  obj-$(CONFIG_MTD_REDBOOT_PARTS)               += redboot.o
index 6b7119b8e0c76e2254a5c838812576206f8d4127..8445900e012b3a5289abc3b4da009df45eca30b3 100644 (file)
@@ -18,7 +18,7 @@ Signed-off-by: Ram Chandra Jangir <rjangi@codeaurora.org>
 
 --- a/drivers/mtd/parsers/Kconfig
 +++ b/drivers/mtd/parsers/Kconfig
-@@ -138,6 +138,13 @@ config MTD_PARSER_TRX
+@@ -153,6 +153,13 @@ config MTD_PARSER_TRX
          This driver will parse TRX header and report at least two partitions:
          kernel and rootfs.
  
@@ -34,9 +34,9 @@ Signed-off-by: Ram Chandra Jangir <rjangi@codeaurora.org>
        depends on MTD_NAND_SHARPSL || MTD_NAND_TMIO || COMPILE_TEST
 --- a/drivers/mtd/parsers/Makefile
 +++ b/drivers/mtd/parsers/Makefile
-@@ -11,6 +11,7 @@ ofpart-$(CONFIG_MTD_OF_PARTS_LINKSYS_NS)
- obj-$(CONFIG_MTD_PARSER_IMAGETAG)     += parser_imagetag.o
+@@ -12,6 +12,7 @@ obj-$(CONFIG_MTD_PARSER_IMAGETAG)    += par
  obj-$(CONFIG_MTD_AFS_PARTS)           += afs.o
+ obj-$(CONFIG_MTD_PARSER_TPLINK_SAFELOADER)    += tplink_safeloader.o
  obj-$(CONFIG_MTD_PARSER_TRX)          += parser_trx.o
 +obj-$(CONFIG_MTD_QCOM_SMEM_PARTS)             += qcom_smem_part.o
  obj-$(CONFIG_MTD_SHARPSL_PARTS)               += sharpslpart.o
index a88687571679e7ab74826bee6276ab9318c070ea..6ee5ce8d64a1bbb4385b810fdea242f1b315f128 100644 (file)
@@ -167,6 +167,7 @@ CONFIG_MODULES_USE_ELF_REL=y
 # CONFIG_MT7621_WDT is not set
 # CONFIG_MTD_CFI_INTELEXT is not set
 CONFIG_MTD_CMDLINE_PARTS=y
+# CONFIG_MTD_PARSER_TPLINK_SAFELOADER is not set
 CONFIG_MTD_PHYSMAP=y
 CONFIG_MTD_SPI_NOR=y
 CONFIG_MTD_SPI_NOR_USE_4K_SECTORS=y
index 057c782760ae6d613e0f5c27254c7667d86b2398..642543f5885360cd39bef8613f074419635cf4cd 100644 (file)
@@ -158,6 +158,7 @@ CONFIG_MTD_CMDLINE_PARTS=y
 CONFIG_MTD_NAND_CORE=y
 CONFIG_MTD_NAND_ECC_SW_HAMMING=y
 CONFIG_MTD_NAND_MT7621=y
+# CONFIG_MTD_PARSER_TPLINK_SAFELOADER is not set
 CONFIG_MTD_PHYSMAP=y
 CONFIG_MTD_RAW_NAND=y
 CONFIG_MTD_ROUTERBOOT_PARTS=y
index dfd01598ad0f767640f051c818d46454d70db0f4..0c53b6f8b475751d7fc37fcfe9f4ffa43f420505 100644 (file)
@@ -164,6 +164,7 @@ CONFIG_MODULES_USE_ELF_REL=y
 CONFIG_MT7621_WDT=y
 # CONFIG_MTD_CFI_INTELEXT is not set
 CONFIG_MTD_CMDLINE_PARTS=y
+# CONFIG_MTD_PARSER_TPLINK_SAFELOADER is not set
 CONFIG_MTD_PHYSMAP=y
 CONFIG_MTD_SPI_NOR=y
 CONFIG_MTD_SPLIT_TPLINK_FW=y