htpdate: Update init script 8104/head
authorJeffery To <jeffery.to@gmail.com>
Fri, 1 Feb 2019 09:21:17 +0000 (17:21 +0800)
committerJeffery To <jeffery.to@gmail.com>
Fri, 1 Feb 2019 09:21:17 +0000 (17:21 +0800)
This replaces the use of uci_validate_section() with
uci_load_validate(), which removes the need to declare local variables
for every config option.

This also corrects a variable name typo ("proxy" instead of
"proxy_host").

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
net/htpdate/Makefile
net/htpdate/files/htpdate.init

index 2650597e87e0b9a2d79f68ae9061fa3b464f914e..adf331a09297ef4e89c7ae540831c6c8c9f27218 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=htpdate
 PKG_VERSION:=1.1.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://www.vervest.org/htp/archive/c/
index 88176c84cc7c3be2d3fee74a388b993f8670b05a..2edd44d2fa28720d2ff67e8d903d11b2bd9c56cd 100644 (file)
@@ -9,7 +9,7 @@ PROG=/usr/sbin/htpdate
 
 
 validate_htpdate_section() {
-       uci_validate_section htpdate htpdate "${1}" \
+       uci_load_validate htpdate htpdate "$1" "$2" \
                'server:list(host)' \
                'proxy_host:host' \
                'proxy_port:port:8080' \
@@ -20,10 +20,10 @@ validate_htpdate_section() {
 }
 
 
-start_service() {
-       local server proxy debug sanity_check option enabled
+start_htpdate_instance() {
+       local peer
 
-        validate_htpdate_section htpdate || {
+       [ "$2" = 0 ] || {
                echo "validation failed"
                return 1
        }
@@ -34,7 +34,7 @@ start_service() {
        procd_open_instance
        procd_set_param command "$PROG" -f
 
-       [ -n "$proxy" ] && procd_append_param command -P $proxy:$proxy_port
+       [ -n "$proxy_host" ] && procd_append_param command -P $proxy_host:$proxy_port
        [ "$debug" = "1" ] && procd_append_param command -d
        [ "$sanity_check" = "0" ] && procd_append_param command -t
        [ -n "$option" ] && procd_append_param command $option
@@ -48,6 +48,10 @@ start_service() {
        procd_close_instance
 }
 
+start_service() {
+       validate_htpdate_section htpdate start_htpdate_instance
+}
+
 service_triggers() {
        procd_add_reload_trigger "htpdate"
        procd_add_validation validate_htpdate_section