golang: split compile recipe into configure and compile
authorMichael Pratt <mcpratt@pm.me>
Fri, 20 May 2022 08:38:41 +0000 (04:38 -0400)
committerMichael Pratt <mcpratt@pm.me>
Fri, 27 May 2022 06:39:52 +0000 (02:39 -0400)
the default Configure recipe for packages
assumes that there is a "configure" script
in the source tree directory

Go does not have such a script,
configure and compile is done with the same script

so split the current Compile recipe
into both Configure and Compile recipes

Signed-off-by: Michael Pratt <mcpratt@pm.me>
lang/golang/golang/Makefile

index 30457910a49231d1ba0068478372b83d32fbb543..c13025cfeee06d04d6abde80670ee6889acf7e9f 100644 (file)
@@ -207,12 +207,14 @@ HOST_GO_VARS= \
        CC="$(HOSTCC_NOCACHE)" \
        CXX="$(HOSTCXX_NOCACHE)"
 
-define Host/Compile
+define Host/Configure
        $(call GoCompiler/Bootstrap/CheckHost,$(BOOTSTRAP_GO_VALID_OS_ARCH))
        $(call GoCompiler/Host/CheckHost,$(HOST_GO_VALID_OS_ARCH))
 
        mkdir -p "$(GO_BUILD_CACHE_DIR)"
+endef
 
+define Host/Compile
        $(call GoCompiler/Bootstrap/Make, \
                $(HOST_GO_VARS) \
        )
@@ -300,9 +302,11 @@ PKG_GO_INSTALL_ARGS= \
        $(if $(PKG_GO_ASMFLAGS),-asmflags "all=$(PKG_GO_ASMFLAGS)") \
        $(if $(filter $(GO_PKG_ENABLE_PIE),1),-buildmode pie)
 
-define Build/Compile
+define Build/Configure
        mkdir -p "$(GO_BUILD_CACHE_DIR)"
+endef
 
+define Build/Compile
        @echo "Building target Go first stage"
 
        $(call GoCompiler/Package/Make, \