qemu: build only qemu-ga
authorYousong Zhou <yszhou4tech@gmail.com>
Thu, 18 Aug 2016 03:23:59 +0000 (11:23 +0800)
committerYousong Zhou <yszhou4tech@gmail.com>
Thu, 18 Aug 2016 03:28:21 +0000 (11:28 +0800)
This has two effects

 - Saves time and computing resources.  Non-relevant tools like
   qemu-img, qemu-io will not be built
 - Fixes packaging failure on octeon target caused by failure of
   building internal pixman library

Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
utils/qemu/Makefile

index 974524d99e01576e423727a9ed866ff304772b96..0990ec0ca83c2e3a1d66d8b1ec28ccb8fb7f38ce 100644 (file)
@@ -42,13 +42,28 @@ CONFIGURE_ARGS:=$(filter-out        \
        --disable-nls           \
        , $(CONFIGURE_ARGS))
 
-# Building qemu-ga alone does not require zlib
-CONFIGURE_ARGS+=                       \
+# Building qemu-ga alone does not require zlib, pixman
+#
+# --disable-tools to disable building pixman which will fail at the moment on
+#  octeon mips64 target.
+CONFIGURE_ARGS +=                      \
        --cross-prefix=$(TARGET_CROSS)  \
        --host-cc="$(HOSTCC)"           \
        --target-list=''                \
        --disable-zlib-test             \
-       --enable-guest-agent
+       --enable-guest-agent            \
+       --disable-tools                 \
+       --without-pixman
+
+ifneq ($(CONFIG_PACKAGE_qemu-ga),)
+CONFIGURE_ARGS += --enable-guest-agent
+endif
+
+MAKE_VARS += V=s
+
+define Build/Compile
+       $(if $(CONFIG_PACKAGE_qemu-ga),$(call Build/Compile/Default,qemu-ga))
+endef
 
 define Package/qemu-ga/install
        $(INSTALL_DIR) $(1)/usr/bin