kernel: bump 4.14 to 4.14.206
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 10 Nov 2020 14:33:17 +0000 (15:33 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 16 Nov 2020 08:35:05 +0000 (09:35 +0100)
Refreshed all patches.

Altered patches:
- 210-dwc2_defaults.patch
- 708-mc-bus-support-layerscape.patch

Fixes:
- CVE-2020-25656

Compile-tested on: ar71xx, cns3xxx, imx6, x86_64
Runtime-tested on: ar71xx, cns3xxx, imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
32 files changed:
include/kernel-version.mk
target/linux/ath79/patches-4.14/0001-tty-serial-drop-QCA-pecific-SoC-symbols.patch
target/linux/brcm2708/patches-4.14/950-0022-Register-the-clocks-early-during-the-boot-process-so.patch
target/linux/brcm2708/patches-4.14/950-0026-clk-bcm2835-Mark-used-PLLs-and-dividers-CRITICAL.patch
target/linux/brcm2708/patches-4.14/950-0027-clk-bcm2835-Add-claim-clocks-property.patch
target/linux/brcm2708/patches-4.14/950-0028-clk-bcm2835-Read-max-core-clock-from-firmware.patch
target/linux/brcm2708/patches-4.14/950-0029-clk-bcm2835-Mark-GPIO-clocks-enabled-at-boot-as-crit.patch
target/linux/brcm2708/patches-4.14/950-0110-drm-vc4-Add-a-mode-for-using-the-closed-firmware-for.patch
target/linux/cns3xxx/patches-4.14/210-dwc2_defaults.patch
target/linux/generic/backport-4.14/030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch
target/linux/generic/hack-4.14/204-module_strip.patch
target/linux/generic/hack-4.14/930-crashlog.patch
target/linux/generic/pending-4.14/203-kallsyms_uncompressed.patch
target/linux/generic/pending-4.14/342-powerpc-Enable-kernel-XZ-compression-option-on-PPC_8.patch
target/linux/generic/pending-4.14/920-mangle_bootargs.patch
target/linux/ipq806x/patches-4.14/0067-generic-Mangle-bootloader-s-kernel-arguments.patch
target/linux/layerscape/patches-4.14/708-mc-bus-support-layerscape.patch
target/linux/layerscape/patches-4.14/807-usb-support-layerscape.patch
target/linux/layerscape/patches-4.14/809-flexcan-support-layerscape.patch
target/linux/mediatek/patches-4.14/0064-dts.patch
target/linux/mediatek/patches-4.14/0124-arm64-mediatek-cleanup-message-for-platform-selectio.patch
target/linux/mpc85xx/patches-4.14/102-powerpc-add-cmdline-override.patch
target/linux/mvebu/patches-4.14/006-mvebu-Mangle-bootloader-s-kernel-arguments.patch
target/linux/mvebu/patches-4.14/411-sfp-add-sfp-compatible.patch
target/linux/mvebu/patches-4.14/508-arm64-dts-armada-3720-espressobin-wire-up-spi-flash.patch
target/linux/mvebu/patches-4.14/514-arm64-dts-marvell-armada-37xx-Enable-emmc-on-espress.patch
target/linux/mvebu/patches-4.14/521-arm64-dts-armada-3720-espressobin-correct-spi-node.patch
target/linux/mvebu/patches-4.14/522-arm64-dts-marvell-armada-3720-espressobin-add-ports-.patch
target/linux/mvebu/patches-4.14/528-arm64-dts-armada-3720-espressobin-set-max-link-to-ge.patch
target/linux/octeon/patches-4.14/110-er200-ethernet_probe_order.patch
target/linux/oxnas/patches-4.14/996-generic-Mangle-bootloader-s-kernel-arguments.patch
target/linux/rb532/patches-4.14/110-korina-update-authors.patch

index a58b17fbf448165250c1b7b04878bfd419ad4a67..e581897dc108c126e0cdea11a0125ccccf249556 100644 (file)
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-4.14 = .202
+LINUX_VERSION-4.14 = .206
 
-LINUX_KERNEL_HASH-4.14.202 = 95c717ab5b0bdd2333e829f0507385fbe3424ceee810727f3a8551a0c74be328
+LINUX_KERNEL_HASH-4.14.206 = 1c233efaa5063983293a02d4692acc9ced9c03e18857364855d4f612347086ac
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 6c4b907e2201d367d43dc9a191372a86d6ef7bf0..216fb316cccb50b2d6cf319ca62e8e2a3a2aa7bc 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
 
 --- a/drivers/tty/serial/Kconfig
 +++ b/drivers/tty/serial/Kconfig
-@@ -1463,7 +1463,7 @@ config SERIAL_XILINX_PS_UART_CONSOLE
+@@ -1464,7 +1464,7 @@ config SERIAL_XILINX_PS_UART_CONSOLE
  
  config SERIAL_AR933X
        tristate "AR933X serial port support"
index fb409b30f549ab7499fd11224ab62584ebe7a34c..3e3ae9b715a88f89ac1ea0694960585936e9135f 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Martin Sperl <kernel@martin.sperl.org>
 
 --- a/drivers/clk/bcm/clk-bcm2835.c
 +++ b/drivers/clk/bcm/clk-bcm2835.c
-@@ -2220,8 +2220,15 @@ static int bcm2835_clk_probe(struct plat
+@@ -2222,8 +2222,15 @@ static int bcm2835_clk_probe(struct plat
        if (ret)
                return ret;
  
@@ -30,7 +30,7 @@ Signed-off-by: Martin Sperl <kernel@martin.sperl.org>
  }
  
  static const struct of_device_id bcm2835_clk_of_match[] = {
-@@ -2238,7 +2245,11 @@ static struct platform_driver bcm2835_cl
+@@ -2240,7 +2247,11 @@ static struct platform_driver bcm2835_cl
        .probe          = bcm2835_clk_probe,
  };
  
index affa877e44dffc91e10c090013a6aaf65a0ca504..22a404361adb03718ddf0818f31a128f1ee9723e 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/clk/bcm/clk-bcm2835.c
 +++ b/drivers/clk/bcm/clk-bcm2835.c
-@@ -1397,6 +1397,11 @@ bcm2835_register_pll_divider(struct bcm2
+@@ -1399,6 +1399,11 @@ bcm2835_register_pll_divider(struct bcm2
        divider->div.hw.init = &init;
        divider->div.table = NULL;
  
index 1e2bddcdb43e490592f591f7f2be897a0bdd0527..fb79013eeadd2a67e1557bab34c41fc31cab9893 100644 (file)
@@ -36,7 +36,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
        pll = kzalloc(sizeof(*pll), GFP_KERNEL);
        if (!pll)
                return NULL;
-@@ -1398,8 +1403,10 @@ bcm2835_register_pll_divider(struct bcm2
+@@ -1400,8 +1405,10 @@ bcm2835_register_pll_divider(struct bcm2
        divider->div.table = NULL;
  
        if (!(cprman_read(cprman, data->cm_reg) & data->hold_mask)) {
@@ -49,7 +49,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
        }
  
        divider->cprman = cprman;
-@@ -2152,6 +2159,8 @@ static const struct bcm2835_clk_desc clk
+@@ -2154,6 +2161,8 @@ static const struct bcm2835_clk_desc clk
                .ctl_reg = CM_PERIICTL),
  };
  
@@ -58,7 +58,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
  /*
   * Permanently take a reference on the parent of the SDRAM clock.
   *
-@@ -2171,6 +2180,19 @@ static int bcm2835_mark_sdc_parent_criti
+@@ -2173,6 +2182,19 @@ static int bcm2835_mark_sdc_parent_criti
        return clk_prepare_enable(parent);
  }
  
@@ -78,7 +78,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
  static int bcm2835_clk_probe(struct platform_device *pdev)
  {
        struct device *dev = &pdev->dev;
-@@ -2180,6 +2202,7 @@ static int bcm2835_clk_probe(struct plat
+@@ -2182,6 +2204,7 @@ static int bcm2835_clk_probe(struct plat
        const struct bcm2835_clk_desc *desc;
        const size_t asize = ARRAY_SIZE(clk_desc_array);
        size_t i;
@@ -86,7 +86,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
        int ret;
  
        cprman = devm_kzalloc(dev, sizeof(*cprman) +
-@@ -2195,6 +2218,13 @@ static int bcm2835_clk_probe(struct plat
+@@ -2197,6 +2220,13 @@ static int bcm2835_clk_probe(struct plat
        if (IS_ERR(cprman->regs))
                return PTR_ERR(cprman->regs);
  
index b232c0c139dc28af47893d95d234ef8ecfe4265e..fe81dc2d41de04c29aa7961b7b885852a1394688 100644 (file)
@@ -90,7 +90,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
        .set_rate = bcm2835_clock_set_rate,
        .determine_rate = bcm2835_clock_determine_rate,
        .set_parent = bcm2835_clock_set_parent,
-@@ -2201,6 +2229,7 @@ static int bcm2835_clk_probe(struct plat
+@@ -2203,6 +2231,7 @@ static int bcm2835_clk_probe(struct plat
        struct resource *res;
        const struct bcm2835_clk_desc *desc;
        const size_t asize = ARRAY_SIZE(clk_desc_array);
@@ -98,7 +98,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
        size_t i;
        u32 clk_id;
        int ret;
-@@ -2218,6 +2247,14 @@ static int bcm2835_clk_probe(struct plat
+@@ -2220,6 +2249,14 @@ static int bcm2835_clk_probe(struct plat
        if (IS_ERR(cprman->regs))
                return PTR_ERR(cprman->regs);
  
index a1150161fd5ee4fbdf6d74676100bf3b62aca8ed..1a120ac0775c5374463db08851822fe8b3da933f 100644 (file)
@@ -20,7 +20,7 @@ Signed-off-by: Eric Anholt <eric@anholt.net>
 
 --- a/drivers/clk/bcm/clk-bcm2835.c
 +++ b/drivers/clk/bcm/clk-bcm2835.c
-@@ -1490,6 +1490,15 @@ static struct clk_hw *bcm2835_register_c
+@@ -1492,6 +1492,15 @@ static struct clk_hw *bcm2835_register_c
        init.flags = data->flags | CLK_IGNORE_UNUSED;
  
        /*
index bd56e4712495f034eba91b9f0a0083e733d5b0ff..b94f09bf402019c4e82f32058e94f8a979214315 100644 (file)
@@ -70,7 +70,7 @@ Signed-off-by: Eric Anholt <eric@anholt.net>
  
 --- a/drivers/gpu/drm/vc4/vc4_drv.c
 +++ b/drivers/gpu/drm/vc4/vc4_drv.c
-@@ -317,6 +317,7 @@ static struct platform_driver *const com
+@@ -318,6 +318,7 @@ static struct platform_driver *const com
        &vc4_dsi_driver,
        &vc4_hvs_driver,
        &vc4_crtc_driver,
index 67f152f43de1f7f57cdf998c3ff038a0af439045..36c7fe0fe99185eb8580f1a223e4f5f319af3de0 100644 (file)
  const struct of_device_id dwc2_of_match_table[] = {
        { .compatible = "brcm,bcm2835-usb", .data = dwc2_set_bcm_params },
        { .compatible = "hisilicon,hi6220-usb", .data = dwc2_set_his_params  },
-@@ -710,17 +740,23 @@ int dwc2_get_hwparams(struct dwc2_hsotg
+@@ -710,18 +740,23 @@ int dwc2_get_hwparams(struct dwc2_hsotg
  
  int dwc2_init_params(struct dwc2_hsotg *hsotg)
  {
 +      /*
        const struct of_device_id *match;
-       void (*set_params)(void *data);
+       void (*set_params)(struct dwc2_hsotg *data);
 +      */
  
        dwc2_set_default_params(hsotg);
@@ -56,8 +56,8 @@
                set_params(hsotg);
        }
 +      */
-+
-+      dwc2_set_cns3xxx_params(hsotg);
  
++      dwc2_set_cns3xxx_params(hsotg);
        dwc2_check_params(hsotg);
  
+       return 0;
index ebd90a8ef2e400f259496092ecea6bec88ff9b0c..4ad22b3de1d8ee9f120f59fc6517de893325bdf2 100644 (file)
@@ -30,7 +30,7 @@ Signed-off-by: Johan Hovold <johan@kernel.org>
 
 --- a/drivers/usb/serial/option.c
 +++ b/drivers/usb/serial/option.c
-@@ -2001,7 +2001,8 @@ static const struct usb_device_id option
+@@ -2011,7 +2011,8 @@ static const struct usb_device_id option
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d01, 0xff) },                   /* D-Link DWM-156 (variant) */
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d02, 0xff) },
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d03, 0xff) },
index c53963c5304f5cb305bd141fac42a778f5754253..d93b545b7ceccde15d5f4c87f9ef69e0fbe74fe7 100644 (file)
@@ -98,7 +98,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
 --- a/init/Kconfig
 +++ b/init/Kconfig
-@@ -1903,6 +1903,13 @@ config TRIM_UNUSED_KSYMS
+@@ -1904,6 +1904,13 @@ config TRIM_UNUSED_KSYMS
  
          If unsure, or if you need to build out-of-tree modules, say N.
  
index 9d09dbd760a89718d8486c561b0bd1bd020894b0..2da51fb406a9c2a467ab08f4db7b7c75e0d751f7 100644 (file)
@@ -41,7 +41,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 +#endif
 --- a/init/Kconfig
 +++ b/init/Kconfig
-@@ -1009,6 +1009,10 @@ config RELAY
+@@ -1010,6 +1010,10 @@ config RELAY
  
          If unsure, say N.
  
index 1f5c83e94f56437b91efc1a5f1f89734175fc215..159a79988f3fb542c734c67df131dab5a821941d 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/init/Kconfig
 +++ b/init/Kconfig
-@@ -1081,6 +1081,17 @@ config SYSCTL_ARCH_UNALIGN_ALLOW
+@@ -1082,6 +1082,17 @@ config SYSCTL_ARCH_UNALIGN_ALLOW
          the unaligned access emulation.
          see arch/parisc/kernel/unaligned.c for reference
  
index e3ae02a06788ac3a8c74b6783da625e8050790bb..09aacec59830a8411f104fc6f5be0e06db006ae4 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
 
 --- a/arch/powerpc/Kconfig
 +++ b/arch/powerpc/Kconfig
-@@ -199,6 +199,7 @@ config PPC
+@@ -200,6 +200,7 @@ config PPC
        select HAVE_IOREMAP_PROT
        select HAVE_IRQ_EXIT_ON_IRQ_STACK
        select HAVE_KERNEL_GZIP
index 2f6a52c23d65b61678cfbbcbbe23b2f5a923a02b..4d7dd3364d95789b9d48c094c25a655b5f33a799 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
 
 --- a/init/Kconfig
 +++ b/init/Kconfig
-@@ -1427,6 +1427,15 @@ config EMBEDDED
+@@ -1428,6 +1428,15 @@ config EMBEDDED
          an embedded system so certain expert options are available
          for configuration.
  
index f0cc3ed509042ea29f361a62fdb54eeac79adcf8..c977dd1001d74cbb736d426df1e17021fbbc1148 100644 (file)
@@ -22,7 +22,7 @@ Signed-off-by: Adrian Panella <ianchi74@outlook.com>
 
 --- a/arch/arm/Kconfig
 +++ b/arch/arm/Kconfig
-@@ -1934,6 +1934,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
+@@ -1936,6 +1936,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
          The command-line arguments provided by the boot loader will be
          appended to the the device tree bootargs property.
  
index 129b8ecc646303d6962476f66f06b05fb4fc1cfc..7c6e25b038aa928cf8325043a9f1bfb4076e66b7 100644 (file)
@@ -8611,7 +8611,7 @@ Signed-off-by: Stuart Yoder <stuart.yoder@nxp.com>
 +}
 --- a/drivers/staging/fsl-mc/bus/mc-io.c
 +++ /dev/null
-@@ -1,292 +0,0 @@
+@@ -1,297 +0,0 @@
 -// SPDX-License-Identifier: (GPL-2.0+ OR BSD-3-Clause)
 -/*
 - * Copyright 2013-2016 Freescale Semiconductor Inc.
@@ -8754,7 +8754,12 @@ Signed-off-by: Stuart Yoder <stuart.yoder@nxp.com>
 - */
 -void fsl_destroy_mc_io(struct fsl_mc_io *mc_io)
 -{
--      struct fsl_mc_device *dpmcp_dev = mc_io->dpmcp_dev;
+-      struct fsl_mc_device *dpmcp_dev;
+-
+-      if (!mc_io)
+-              return;
+-
+-      dpmcp_dev = mc_io->dpmcp_dev;
 -
 -      if (dpmcp_dev)
 -              fsl_mc_io_unset_dpmcp(mc_io);
index a986278c4011607dc6fd7c851374b546c39ae839..449165dca1b22b3a278280319b2005587201e24f 100644 (file)
@@ -382,7 +382,7 @@ Signed-off-by: Zhao Chenhui <chenhui.zhao@freescale.com>
        dwc->lpm_nyet_threshold = lpm_nyet_threshold;
        dwc->tx_de_emphasis = tx_de_emphasis;
  
-@@ -1376,12 +1541,14 @@ static int dwc3_resume_common(struct dwc
+@@ -1387,12 +1552,14 @@ static int dwc3_resume_common(struct dwc
  
        switch (dwc->dr_mode) {
        case USB_DR_MODE_PERIPHERAL:
@@ -1206,7 +1206,7 @@ Signed-off-by: Zhao Chenhui <chenhui.zhao@freescale.com>
        struct list_head        cached_itd_list;
 --- a/drivers/usb/host/fsl-mph-dr-of.c
 +++ b/drivers/usb/host/fsl-mph-dr-of.c
-@@ -229,6 +229,17 @@ static int fsl_usb2_mph_dr_of_probe(stru
+@@ -232,6 +232,17 @@ static int fsl_usb2_mph_dr_of_probe(stru
        pdata->has_fsl_erratum_a005697 =
                of_property_read_bool(np, "fsl,usb_erratum-a005697");
  
index 75a6d97adbffe5887de7ddedc417cae8739a1e50..d1849a5699f6a417dc52f9ff34bf86990b300823 100644 (file)
@@ -512,8 +512,8 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
  
        return 0;
  
-@@ -1069,10 +1086,10 @@ static void flexcan_chip_stop(struct net
-       flexcan_chip_disable(priv);
+@@ -1074,10 +1091,10 @@ static int __flexcan_chip_stop(struct ne
+               goto out_chip_unfreeze;
  
        /* Disable all interrupts */
 -      flexcan_write(0, &regs->imask2);
@@ -527,7 +527,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
  
        flexcan_transceiver_disable(priv);
        priv->can.state = CAN_STATE_STOPPED;
-@@ -1187,26 +1204,26 @@ static int register_flexcandev(struct ne
+@@ -1209,26 +1226,26 @@ static int register_flexcandev(struct ne
        err = flexcan_chip_disable(priv);
        if (err)
                goto out_disable_per;
@@ -559,7 +559,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
        if (!(reg & FLEXCAN_MCR_FEN)) {
                netdev_err(dev, "Could not enable RX FIFO, unsupported core\n");
                err = -ENODEV;
-@@ -1234,8 +1251,12 @@ static void unregister_flexcandev(struct
+@@ -1256,8 +1273,12 @@ static void unregister_flexcandev(struct
  static const struct of_device_id flexcan_of_match[] = {
        { .compatible = "fsl,imx6q-flexcan", .data = &fsl_imx6q_devtype_data, },
        { .compatible = "fsl,imx28-flexcan", .data = &fsl_imx28_devtype_data, },
@@ -572,7 +572,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
        { /* sentinel */ },
  };
  MODULE_DEVICE_TABLE(of, flexcan_of_match);
-@@ -1315,6 +1336,21 @@ static int flexcan_probe(struct platform
+@@ -1337,6 +1358,21 @@ static int flexcan_probe(struct platform
        dev->flags |= IFF_ECHO;
  
        priv = netdev_priv(dev);
index a2f5000d4d16975d89c626fb67705583e4a6fbd7..8cfda5003597a78bd977ae94c2e04fb1484a5e3e 100644 (file)
                                        reg = <6>;
                                        label = "cpu";
                                        ethernet = <&gmac0>;
-@@ -187,8 +227,6 @@
+@@ -188,8 +228,6 @@
                                };
                        };
                };
index 6af0ae83163a637daa74906b609d3d97321d0890..1f8a549aac73b23246c911798731da1e38dd8b5f 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: Matthias Brugger <matthias.bgg@gmail.com>
 
 --- a/arch/arm64/Kconfig.platforms
 +++ b/arch/arm64/Kconfig.platforms
-@@ -91,12 +91,13 @@ config ARCH_HISI
+@@ -92,12 +92,13 @@ config ARCH_HISI
          This enables support for Hisilicon ARMv8 SoC family
  
  config ARCH_MEDIATEK
index 087798e3d813ed3c878348de6dae64add7e51106..a1fd3eda13b39b0fcd87eaf893aa235c532f0ebb 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/powerpc/Kconfig
 +++ b/arch/powerpc/Kconfig
-@@ -837,6 +837,14 @@ config CMDLINE_FORCE
+@@ -838,6 +838,14 @@ config CMDLINE_FORCE
          This is useful if you cannot or don't want to change the
          command-line options your boot loader passes to the kernel.
  
index 4ef86edb6ab492ec9d7a505b4466d97b85230c81..f9d902b4d988650d8276da205b8d28bbc8edf7e3 100644 (file)
@@ -28,7 +28,7 @@ Signed-off-by: Michael Gray <michael.gray@lantisproject.com>
 
 --- a/arch/arm/Kconfig
 +++ b/arch/arm/Kconfig
-@@ -1934,6 +1934,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
+@@ -1936,6 +1936,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
          The command-line arguments provided by the boot loader will be
          appended to the the device tree bootargs property.
  
index 9174765e6a34cdc76c59f6e7388d64b6d937f271..6fce278305160d8d557a82f16bf968de2fdbc21e 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Russell King <rmk+kernel@armlinux.org.uk>
 
 --- a/drivers/net/phy/sfp.c
 +++ b/drivers/net/phy/sfp.c
-@@ -1168,6 +1168,7 @@ static int sfp_remove(struct platform_de
+@@ -1169,6 +1169,7 @@ static int sfp_remove(struct platform_de
  
  static const struct of_device_id sfp_of_match[] = {
        { .compatible = "sff,sfp", },
index 840897473fb2987772de60f7e1828baa66d3cd82..6395a3573d6a43c09a1081ca25c8ec261112ae4b 100644 (file)
@@ -20,7 +20,7 @@ Signed-off-by: Gregory CLEMENT <gregory.clement@bootlin.com>
 
 --- a/arch/arm64/boot/dts/marvell/armada-3720-espressobin.dts
 +++ b/arch/arm64/boot/dts/marvell/armada-3720-espressobin.dts
-@@ -96,6 +96,33 @@
+@@ -100,6 +100,33 @@
        status = "okay";
  };
  
index 26d090f050b21b9e921e69a75bd37f5af050569f..77d9956fff702a4d8f9fd3c7ac2d7c514044f6af 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Gregory CLEMENT <gregory.clement@bootlin.com>
 
 --- a/arch/arm64/boot/dts/marvell/armada-3720-espressobin.dts
 +++ b/arch/arm64/boot/dts/marvell/armada-3720-espressobin.dts
-@@ -93,9 +93,31 @@
+@@ -97,9 +97,31 @@
        cd-gpios = <&gpionb 3 GPIO_ACTIVE_LOW>;
        marvell,pad-type = "sd";
        vqmmc-supply = <&vcc_sd_reg1>;
index fc7cb2af1ee7def3a216237c3dec68eddf87edf5..5c3f214d1e0d0277f3cb2c1c549975a3a903a9f3 100644 (file)
@@ -29,7 +29,7 @@ Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
 
 --- a/arch/arm64/boot/dts/marvell/armada-3720-espressobin.dts
 +++ b/arch/arm64/boot/dts/marvell/armada-3720-espressobin.dts
-@@ -123,25 +123,9 @@
+@@ -127,25 +127,9 @@
  
        flash@0 {
                reg = <0>;
index d0103bba1967b88842584581b00de493330ae25e..bef9c402867b877a7a17ed23bb1bcf10e91e5db9 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
 
 --- a/arch/arm64/boot/dts/marvell/armada-3720-espressobin.dts
 +++ b/arch/arm64/boot/dts/marvell/armada-3720-espressobin.dts
-@@ -153,7 +153,7 @@
+@@ -157,7 +157,7 @@
  
                dsa,member = <0 0>;
  
index 5ff9b472682c9c568f75254e38450eceaee9562b..6ce49f71f0c7f20354aa7fcd01628d70878f2cc3 100644 (file)
@@ -62,7 +62,7 @@ Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
 
 --- a/arch/arm64/boot/dts/marvell/armada-3720-espressobin.dts
 +++ b/arch/arm64/boot/dts/marvell/armada-3720-espressobin.dts
-@@ -79,6 +79,8 @@
+@@ -83,6 +83,8 @@
  /* J9 */
  &pcie0 {
        status = "okay";
index 6b1eaf92a2b0c06b7e416700437898f2513e89ab..e5330ffbd68a8d4b10273c7b355fc86e1c31cf16 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/staging/octeon/ethernet.c
 +++ b/drivers/staging/octeon/ethernet.c
-@@ -673,6 +673,7 @@ static int cvm_oct_probe(struct platform
+@@ -674,6 +674,7 @@ static int cvm_oct_probe(struct platform
        int interface;
        int fau = FAU_NUM_PACKET_BUFFERS_TO_FREE;
        int qos;
@@ -8,7 +8,7 @@
        struct device_node *pip;
        int mtu_overhead = ETH_HLEN + ETH_FCS_LEN;
  
-@@ -796,13 +797,19 @@ static int cvm_oct_probe(struct platform
+@@ -797,13 +798,19 @@ static int cvm_oct_probe(struct platform
        }
  
        num_interfaces = cvmx_helper_get_number_of_interfaces();
index a06825f7c87b4ff7361c8b7ebb8e1bdbb5205556..313b9b564010d12bf3d720fc4dcf09e11decbef0 100644 (file)
@@ -22,7 +22,7 @@ Signed-off-by: Adrian Panella <ianchi74@outlook.com>
 
 --- a/arch/arm/Kconfig
 +++ b/arch/arm/Kconfig
-@@ -1934,6 +1934,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
+@@ -1936,6 +1936,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
          The command-line arguments provided by the boot loader will be
          appended to the the device tree bootargs property.
  
index 843397cf37d0730eb7c049b7c622bce2925f5a5b..ee6dd95741a79cad0dbe9613846260dbff01b7b8 100644 (file)
@@ -8,7 +8,7 @@
   *
   *  This program is free software; you can redistribute  it and/or modify it
   *  under  the terms of  the GNU General  Public License as published by the
-@@ -1150,5 +1151,6 @@ module_platform_driver(korina_driver);
+@@ -1151,5 +1152,6 @@ module_platform_driver(korina_driver);
  MODULE_AUTHOR("Philip Rischel <rischelp@idt.com>");
  MODULE_AUTHOR("Felix Fietkau <nbd@openwrt.org>");
  MODULE_AUTHOR("Florian Fainelli <florian@openwrt.org>");