python3: add python3-package-lzma.mk 1189/head
authorAlexandru Ardelean <ardeleanalex@gmail.com>
Fri, 24 Apr 2015 10:04:56 +0000 (13:04 +0300)
committerAlexandru Ardelean <ardeleanalex@gmail.com>
Fri, 24 Apr 2015 10:04:56 +0000 (13:04 +0300)
Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
lang/python3/files/python3-package-lzma.mk [new file with mode: 0644]

diff --git a/lang/python3/files/python3-package-lzma.mk b/lang/python3/files/python3-package-lzma.mk
new file mode 100644 (file)
index 0000000..b04f072
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Package/python3-lzma
+$(call Package/python3/Default)
+  TITLE:=Python $(PYTHON3_VERSION) lzma module
+  DEPENDS:=+python3-light +liblzma
+endef
+
+$(eval $(call Py3BasePackage,python3-lzma, \
+       /usr/lib/python$(PYTHON3_VERSION)/lzma.py \
+       /usr/lib/python$(PYTHON3_VERSION)/lib-dynload/_lzma.$(PYTHON3_SO_SUFFIX) \
+))