[packages_10.03.2] tmux: merge r27847, r27848, r27854, r27981, r29964
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 4 Feb 2012 21:06:24 +0000 (21:06 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 4 Feb 2012 21:06:24 +0000 (21:06 +0000)
SVN-Revision: 30158

utils/tmux/Makefile

index eaa45bbd74f4dfe2a3533f8012e1a3b3a2a28d30..71d02ea313c25a4170fd78069f9d7319636c6758 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2011 OpenWrt.org
+# Copyright (C) 2009-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tmux
-PKG_VERSION:=1.4
+PKG_VERSION:=1.6
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/tmux
-PKG_MD5SUM:=0bfc7dd9a5bab192406167589c716a21
+PKG_MD5SUM:=3e37db24aa596bf108a0442a81c845b3
 
 PKG_INSTALL:=1
 
@@ -23,7 +23,7 @@ define Package/tmux
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=Terminal multiplexer
-  DEPENDS:=+libncurses +libevent +libpthread
+  DEPENDS:=+libncurses +libevent2 +libpthread +librt
   URL:=http://tmux.sourceforge.net/
 endef
 
@@ -33,7 +33,7 @@ endef
 
 MAKE_FLAGS += \
        PREFIX="/usr" \
-       TMUX_PLATFORM="Linux" \
+       PLATFORM="linux"
 
 define Package/tmux/install
        $(INSTALL_DIR) $(1)/usr/bin