openocd: fix package dependencies 851/head
authorPaul Fertser <fercerpav@gmail.com>
Tue, 3 Feb 2015 14:11:37 +0000 (17:11 +0300)
committerPaul Fertser <fercerpav@gmail.com>
Tue, 3 Feb 2015 14:11:37 +0000 (17:11 +0300)
OpenOCD autoselects libftdi1 when it's present, and should explicitly
depend on it, same about libusb-0.1 API which is provided by
libusb-compat.

Signed-off-by: Paul Fertser <fercerpav@gmail.com>
utils/openocd/Makefile

index 929574b90cbc857c1d2d89b45fe072ca3b8ad924..aadd3e2f3bf0a8e603f3d6d688c5f1d8744c5c8c 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openocd
 PKG_VERSION:=v0.8.0-258-gd537cfa
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://git.code.sf.net/p/openocd/code
@@ -32,7 +32,7 @@ define Package/openocd
   CATEGORY:=Utilities
   TITLE:=OpenOCD Utility
   URL:=http://openocd.sf.net/
-  DEPENDS:=+libusb-1.0 +libftdi +hidapi
+  DEPENDS:=+libusb-1.0 +libusb-compat +libftdi1 +hidapi
 endef
 
 define Package/openocd/description