we have no diff tool, ipkg should not ask
authorWaldemar Brodkorb <mail@waldemar-brodkorb.de>
Mon, 12 Sep 2005 17:09:46 +0000 (17:09 +0000)
committerWaldemar Brodkorb <mail@waldemar-brodkorb.de>
Mon, 12 Sep 2005 17:09:46 +0000 (17:09 +0000)
SVN-Revision: 1911

openwrt/package/ipkg/Makefile
openwrt/package/ipkg/patches/no-diff.patch [new file with mode: 0644]

index 185c5f81cc66554126731c0cf9a2a1ce6af27900..cdae220cba311c8ddf6d964b151528001d52d56a 100644 (file)
@@ -4,7 +4,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ipkg
 PKG_VERSION:=0.99.149
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_MD5SUM:=975cc419d6db5fb279dc58177c68373b
 
 PKG_SOURCE_URL:=http://www.handhelds.org/packages/ipkg
diff --git a/openwrt/package/ipkg/patches/no-diff.patch b/openwrt/package/ipkg/patches/no-diff.patch
new file mode 100644 (file)
index 0000000..60c5860
--- /dev/null
@@ -0,0 +1,35 @@
+diff -Nur ipkg-0.99.149.orig/ipkg_install.c ipkg-0.99.149/ipkg_install.c
+--- ipkg-0.99.149.orig/ipkg_install.c  2005-03-30 14:08:13.000000000 +0200
++++ ipkg-0.99.149/ipkg_install.c       2005-09-12 17:37:53.287558000 +0200
+@@ -1416,9 +1416,8 @@
+                                      "       What would you like to do about it ?  Your options are:\n"
+                                      "        Y or I  : install the package maintainer's version\n"
+                                      "        N or O  : keep your currently-installed version\n"
+-                                     "          D     : show the differences between the versions (if diff is installed)\n"
+                                      "     The default action is to keep your current version.\n"
+-                                     "    *** %s (Y/I/N/O/D) [default=N] ? ", file_name, short_file_name);
++                                     "    *** %s (Y/I/N/O) [default=N] ? ", file_name, short_file_name);
+         if (strcmp(response, "y") == 0
+             || strcmp(response, "i") == 0
+             || strcmp(response, "yes") == 0) {
+@@ -1426,20 +1425,6 @@
+              return 0;
+         }
+-        if (strcmp(response, "d") == 0) {
+-             char *cmd;
+-
+-             free(response);
+-             /* XXX: BUG rewrite to use exec or busybox's internal diff */
+-             sprintf_alloc(&cmd, "diff -u %s %s", backup, file_name);
+-             xsystem(cmd);
+-             free(cmd);
+-             printf("    [Press ENTER to continue]\n");
+-             response = file_read_line_alloc(stdin);
+-             free(response);
+-             continue;
+-        }
+-
+         free(response);
+         return 1;
+      }