node-mozilla-iot-gateway: Cleanup init script 7475/head
authorMichal Hrusecky <michal.hrusecky@nic.cz>
Mon, 19 Nov 2018 16:23:14 +0000 (17:23 +0100)
committerMichal Hrusecky <michal.hrusecky@nic.cz>
Mon, 19 Nov 2018 16:23:14 +0000 (17:23 +0100)
Migrates to procd (and fixes actual shutdown of the service) and also avoids
writing log to roots home directory by using system log.

Signed-off-by: Michal Hrusecky <michal.hrusecky@nic.cz>
lang/node-mozilla-iot-gateway/Makefile
lang/node-mozilla-iot-gateway/files/mozilla-iot-gateway.init

index 9bf7d4b1ad07881d2bde8966c5534b58c04773d9..d2252259a1938b8ca863f5627c92eeafaadaa7ed 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NPM_NAME:=mozilla-iot-gateway
 PKG_NAME:=node-$(PKG_NPM_NAME)
 PKG_VERSION:=0.6.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_REV:=df2d06def2051238bde7b8e5ee306262235d4c9f
 
 PKG_SOURCE_PROTO:=git
index 7bd3836cab3f200e14ab12ab6814881bbdd45474..8ed67fcac364a4aa959dcd836df681a7d0a3d2c0 100644 (file)
@@ -2,26 +2,20 @@
 
 START=99
 
+USE_PROCD=1
+
 HOME=/root
 MOZIOT_HOME="${HOME}/.mozilla-iot"
 export PATH="/opt/mozilla-iot/gateway/tools:${PATH}"
 
-run_app() {
-       cd /opt/mozilla-iot/gateway
-
-       echo "node version"
-       node --version
-       echo "npm version"
-       npm --version
-       echo "Starting gateway ..."
-       npm start
-}
-
-start()
+start_service()
 {
        mkdir -p /usr/etc/
        ln -sf /etc/openzwave /usr/etc/openzwave
 
-       mkdir -p "${MOZIOT_HOME}/log"
-       run_app &> "${MOZIOT_HOME}/log/run-app.log" &
+       procd_open_instance mozilla-iot-gateway
+       procd_set_param command /usr/bin/npm start --prefix /opt/mozilla-iot/gateway
+       procd_set_param stdout 1
+       procd_set_param stderr 1
+       procd_close_instance
 }