[openssh]: remove obsolete lines
authorPeter Wagner <​tripolar@gmx.at>
Tue, 8 Feb 2011 00:05:48 +0000 (00:05 +0000)
committerPeter Wagner <​tripolar@gmx.at>
Tue, 8 Feb 2011 00:05:48 +0000 (00:05 +0000)
SVN-Revision: 25416

net/openssh/Makefile

index f2846143486f41bbdca2a51e6f8412f563f54701..8f83a5e6cfebab47f583f54a64dfe269747bba6d 100644 (file)
@@ -181,24 +181,6 @@ define Package/openssh-server/postinst
 name=sshd
 id=22
 
-# do not change below
-# check if we are on real system
-if [ -z "$${IPKG_INSTROOT}" ]; then
-       # create copies of passwd and group, if we use squashfs
-       rootfs=`mount |awk '/root/ { print $$5 }'`
-       if [ "$$rootfs" = "squashfs" ]; then
-               if [ -h /etc/group ]; then
-                       rm /etc/group
-                       cp /rom/etc/group /etc/group
-               fi
-               if [ -h /etc/passwd ]; then
-                       rm /etc/passwd
-                       cp /rom/etc/passwd /etc/passwd
-               fi
-       fi
-fi
-
-echo ""
 if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/group)" ]; then
        echo "adding group $$name to /etc/group"
        echo "$${name}:x:$${id}:" >> $${IPKG_INSTROOT}/etc/group