ramips: add encrypted SGE factory image for D-Link devices
authorAlan Luck <luckyhome2008@gmail.com>
Tue, 7 Nov 2023 22:10:35 +0000 (09:10 +1100)
committerDavid Bauer <mail@david-bauer.net>
Mon, 8 Jan 2024 20:13:30 +0000 (21:13 +0100)
creates SGE encrypted factory images
to use via the D-Link web interface
rename the old factory unencrypted images to recovery
for use in the recovery console when recovery is needed

adjusted to not touch unrelated devices

Signed-off-by: Alan Luck <luckyhome2008@gmail.com>
(cherry picked and adjusted from commit 4c0dc68f466588bb2ef60b29a4d8052b34112ca6)
Signed-off-by: Florian Maurer <f.maurer@outlook.de>
include/image-commands.mk

index dc6ee6e7c160c0935c3d72fb26b88c4ebcf4b028..6666eddf8f72d3ad49aafe1b08d79c26e0089945 100644 (file)
@@ -226,6 +226,11 @@ define Build/copy-file
        cat "$(1)" > "$@"
 endef
 
+define Build/dlink-sge-image
+       $(STAGING_DIR_HOST)/bin/dlink-sge-image $(1) $@ $@.enc
+       mv $@.enc $@
+endef
+
 define Build/edimax-header
        $(STAGING_DIR_HOST)/bin/mkedimaximg -i $@ -o $@.new $(1)
        @mv $@.new $@