nfdump: add flex to dependencies
authorMichael Pratt <mcpratt@pm.me>
Thu, 25 Aug 2022 19:06:28 +0000 (15:06 -0400)
committerRosen Penev <rosenp@gmail.com>
Fri, 9 Sep 2022 22:20:58 +0000 (15:20 -0700)
This package uses the macro
AC_PROG_LEX(yywrap)
which in new versions of GNU Autoconf
specifically looks for the yywrap function in the libraries,
and considers lex/flex not present if the function is not found.

Signed-off-by: Michael Pratt <mcpratt@pm.me>
net/nfdump/Makefile

index 6496352cb6939c3fa29347a2c9cc1f438d386c94..cab9d97074933e8451d111d3a50357c54bba673e 100644 (file)
@@ -26,7 +26,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/nfdump
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:= +libbz2 +USE_MUSL:musl-fts
+  DEPENDS:= +flex +libbz2 +USE_MUSL:musl-fts
   TITLE:= nfdump
   URL:=https://github.com/phaag/nfdump/
 endef