dahdi-tools: clean up make flags, remove $(FPIC)
authorSebastian Kemper <sebastian_ml@gmx.net>
Sat, 24 Feb 2018 09:15:20 +0000 (10:15 +0100)
committerSebastian Kemper <sebastian_ml@gmx.net>
Sat, 24 Feb 2018 09:15:22 +0000 (10:15 +0100)
- Remove all flags/variables that are not used at all.

- dahdi-tools already makes sure that the compiler emits
  position-independent code for libtonezone. Adding $(FPIC) makes no
  difference. In addition the dahdi-toolsbuild system puts its own flag
  behind the CFLAGS, overriding whatever was set before. Also the
  applications should never be built with PIC, it should only be done for
  the lib.

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
libs/dahdi-tools/Makefile

index 05fef5421cef5f0c9b18cb4eb938a365c4c59e00..e9a7cb9dbc41cb7b352279a7ef098182553aedea 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2014 OpenWrt.org
+# Copyright (C) 2014 - 2018 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -46,20 +46,12 @@ define Package/dahdi-tools-libtonezone
   TITLE:=DAHDI tonezone library
 endef
 
-TARGET_CFLAGS += $(FPIC)
-EXTRA_CFLAGS:= $(TARGET_CPPFLAGS)
-
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
                HOSTCC="$(HOSTCC)" \
                CROSS_COMPILE="$(TARGET_CROSS)" \
-               CFLAGS="$(TARGET_CFLAGS) -I. -DBUILDING_TONEZONE -I$(STAGING_DIR)/usr/include" \
-               KSRC="$(LINUX_DIR)" \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               INSTALL_PREFIX="$(PKG_INSTALL_DIR)" \
-               DAHDI_INCLUDE="$(STAGING_DIR)/usr/include" \
-               CONFIGURE_SILENT="--silent" \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="$(TARGET_CPPFLAGS)" \
                dahdi_cfg dahdi_monitor dahdi_scan dahdi_speed dahdi_test fxotune
 endef