python3-asgiref: Update to 3.7.2, rename source package
authorJeffery To <jeffery.to@gmail.com>
Tue, 6 Jun 2023 09:50:18 +0000 (17:50 +0800)
committerRosen Penev <rosenp@gmail.com>
Wed, 7 Jun 2023 20:19:54 +0000 (23:19 +0300)
This renames the source package to python-asgiref to match other Python
packages.

This also updates the package title and URL.

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
lang/python/python-asgiref/Makefile [new file with mode: 0644]
lang/python/python3-asgiref/Makefile [deleted file]

diff --git a/lang/python/python-asgiref/Makefile b/lang/python/python-asgiref/Makefile
new file mode 100644 (file)
index 0000000..4547758
--- /dev/null
@@ -0,0 +1,34 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-asgiref
+PKG_VERSION:=3.7.2
+PKG_RELEASE:=1
+
+PYPI_NAME:=asgiref
+PKG_HASH:=9e0ce3aa93a819ba5b45120216b23878cf6e8525eb3848653452b4192b92afed
+
+PKG_MAINTAINER:=Peter Stadler <peter.stadler@student.uibk.ac.at>
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-asgiref
+  SUBMENU:=Python
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=ASGI specs, helper code, and adapters
+  URL:=https://github.com/django/asgiref/
+  DEPENDS:=+python3-light +python3-logging +python3-asyncio
+endef
+
+define Package/python3-asgiref/description
+  ASGI is a standard for Python asynchronous web apps and servers to communicate
+  with each other, and positioned as an asynchronous successor to WSGI.
+endef
+
+$(eval $(call Py3Package,python3-asgiref))
+$(eval $(call BuildPackage,python3-asgiref))
+$(eval $(call BuildPackage,python3-asgiref-src))
diff --git a/lang/python/python3-asgiref/Makefile b/lang/python/python3-asgiref/Makefile
deleted file mode 100644 (file)
index d92ec91..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=asgiref
-PKG_VERSION:=3.4.1
-PKG_RELEASE:=2
-
-PYPI_NAME:=asgiref
-PKG_HASH:=4ef1ab46b484e3c706329cedeff284a5d40824200638503f5768edb6de7d58e9
-
-PKG_MAINTAINER:=Peter Stadler <peter.stadler@student.uibk.ac.at>
-PKG_LICENSE:=BSD-3-Clause
-PKG_LICENSE_FILES:=LICENSE
-
-include ../pypi.mk
-include $(INCLUDE_DIR)/package.mk
-include ../python3-package.mk
-
-define Package/python3-asgiref
-  SUBMENU:=Python
-  SECTION:=lang
-  CATEGORY:=Languages
-  TITLE:=Standard for Python asynchronous web apps and servers.
-  URL:=https://asgi.readthedocs.io/en/latest/
-  DEPENDS:=+python3-light +python3-logging +python3-asyncio
-endef
-
-define Package/python3-asgiref/description
-  ASGI is a standard for Python asynchronous web apps and servers to communicate
-  with each other, and positioned as an asynchronous successor to WSGI.
-endef
-
-$(eval $(call Py3Package,python3-asgiref))
-$(eval $(call BuildPackage,python3-asgiref))
-$(eval $(call BuildPackage,python3-asgiref-src))