dropbear: restore performance by disabling mips16
authorJonas Gorski <jogo@openwrt.org>
Thu, 21 Aug 2014 11:29:04 +0000 (11:29 +0000)
committerJonas Gorski <jogo@openwrt.org>
Thu, 21 Aug 2014 11:29:04 +0000 (11:29 +0000)
Disable MIPS16 to prevent it negatively affecting performance.
Observed was a increase of connection delay from ~6 to ~11 seconds
and a reduction of scp speed from 1.1MB/s to 710kB/s on brcm63xx.

Fixes #15209.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 42250

package/network/services/dropbear/Makefile

index f793e9b8a76b00815e30c186541034df3de7d229..d805f00cd3aabb02045d176d16e9afe951d75910 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dropbear
 PKG_VERSION:=2014.65
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
@@ -21,6 +21,7 @@ PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=LICENSE libtomcrypt/LICENSE libtommath/LICENSE
 
 PKG_BUILD_PARALLEL:=1
+PKG_USE_MIPS16:=0
 
 PKG_CONFIG_DEPENDS:=CONFIG_DROPBEAR_ECC