tmux: update to 2.0
authorLuka Perkov <luka@openwrt.org>
Wed, 13 May 2015 10:39:48 +0000 (12:39 +0200)
committerLuka Perkov <luka@openwrt.org>
Wed, 13 May 2015 10:39:48 +0000 (12:39 +0200)
Signed-off-by: Luka Perkov <luka@openwrt.org>
utils/tmux/Makefile
utils/tmux/patches/100-b64_ntop-conflict.patch [new file with mode: 0644]
utils/tmux/patches/100-b64_ntop-conflict_compath_h.patch [deleted file]
utils/tmux/patches/101-b64_ntop-conflict_compat_b64_ntop_c.patch [deleted file]
utils/tmux/patches/102-b64_ntop-conflict_tty_c.patch [deleted file]
utils/tmux/patches/200-usr-local.patch [deleted file]

index 1a7e6d147c62a609823855e7faf301f6b25272e2..db13ff5b93af05391c8a8d61e460c390acb25be4 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2012 OpenWrt.org
+# Copyright (C) 2009-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,16 +8,18 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tmux
-PKG_VERSION:=1.9a
+PKG_VERSION:=2.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/tmux
-PKG_MD5SUM:=b07601711f96f1d260b390513b509a2d
+PKG_MD5SUM:=9fb6b443392c3978da5d599f1e814eaa
 PKG_MAINTAINER:=Maxim Storchak <m.storchak@gmail.com>
+
 PKG_LICENSE:=ISC
 PKG_LICENSE_FILES:=COPYING
 
+PKG_BUILD_PARALLEL:=1
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
diff --git a/utils/tmux/patches/100-b64_ntop-conflict.patch b/utils/tmux/patches/100-b64_ntop-conflict.patch
new file mode 100644 (file)
index 0000000..6350f5b
--- /dev/null
@@ -0,0 +1,35 @@
+--- a/compat.h
++++ b/compat.h
+@@ -230,7 +230,9 @@ int                 daemon(int, int);
+ #ifndef HAVE_B64_NTOP
+ /* b64_ntop.c */
+ #undef b64_ntop /* for Cygwin */
+-int            b64_ntop(const char *, size_t, char *, size_t);
++int            local_b64_ntop(const char *, size_t, char *, size_t);
++#else
++#define local_b64_ntop b64_ntop
+ #endif
+ #ifndef HAVE_FORKPTY
+--- a/tty.c
++++ b/tty.c
+@@ -1070,7 +1070,7 @@ tty_cmd_setselection(struct tty *tty, co
+       off = 4 * ((ctx->num + 2) / 3) + 1; /* storage for base64 */
+       buf = xmalloc(off);
+-      b64_ntop(ctx->ptr, ctx->num, buf, off);
++      local_b64_ntop(ctx->ptr, ctx->num, buf, off);
+       tty_putcode_ptr2(tty, TTYC_MS, "", buf);
+       free(buf);
+--- a/compat/b64_ntop.c
++++ b/compat/b64_ntop.c
+@@ -122,7 +122,7 @@ static const char Pad64 = '=';
+    */
+ int
+-b64_ntop(uint8_t const *src, size_t srclength, char *target, size_t targsize) {
++local_b64_ntop(uint8_t const *src, size_t srclength, char *target, size_t targsize) {
+       size_t datalength = 0;
+       uint8_t input[3];
+       uint8_t output[4];
diff --git a/utils/tmux/patches/100-b64_ntop-conflict_compath_h.patch b/utils/tmux/patches/100-b64_ntop-conflict_compath_h.patch
deleted file mode 100644 (file)
index 3b21669..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/compat.h b/compat.h
-index 65d6ec7..7fc3aa7 100644
---- a/compat.h
-+++ b/compat.h
-@@ -219,7 +219,9 @@ int                 daemon(int, int);
- #ifndef HAVE_B64_NTOP
- /* b64_ntop.c */
- #undef b64_ntop /* for Cygwin */
--int            b64_ntop(const char *, size_t, char *, size_t);
-+int            local_b64_ntop(const char *, size_t, char *, size_t);
-+#else
-+#define local_b64_ntop b64_ntop
- #endif
- #ifndef HAVE_FORKPTY
diff --git a/utils/tmux/patches/101-b64_ntop-conflict_compat_b64_ntop_c.patch b/utils/tmux/patches/101-b64_ntop-conflict_compat_b64_ntop_c.patch
deleted file mode 100644 (file)
index a03d18f..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/compat/b64_ntop.c b/compat/b64_ntop.c
-index 2b4dc2d..a1314ca 100644
---- a/compat/b64_ntop.c
-+++ b/compat/b64_ntop.c
-@@ -122,7 +122,7 @@ static const char Pad64 = '=';
-    */
- int
--b64_ntop(uint8_t const *src, size_t srclength, char *target, size_t targsize) {
-+local_b64_ntop(uint8_t const *src, size_t srclength, char *target, size_t targsize) {
-       size_t datalength = 0;
-       uint8_t input[3];
-       uint8_t output[4];
diff --git a/utils/tmux/patches/102-b64_ntop-conflict_tty_c.patch b/utils/tmux/patches/102-b64_ntop-conflict_tty_c.patch
deleted file mode 100644 (file)
index 72e0a07..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/tty.c b/tty.c
-index eb2511c..576edbc 100644
---- a/tty.c
-+++ b/tty.c
-@@ -1067,7 +1067,7 @@ tty_cmd_setselection(struct tty *tty, const struct tty_ctx *ctx)
-       off = 4 * ((ctx->num + 2) / 3) + 1; /* storage for base64 */
-       buf = xmalloc(off);
--      b64_ntop(ctx->ptr, ctx->num, buf, off);
-+      local_b64_ntop(ctx->ptr, ctx->num, buf, off);
-       tty_putcode_ptr2(tty, TTYC_MS, "", buf);
-       free(buf);
diff --git a/utils/tmux/patches/200-usr-local.patch b/utils/tmux/patches/200-usr-local.patch
deleted file mode 100644 (file)
index 07336de..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -101,9 +101,9 @@ bin_PROGRAMS = tmux$(EXEEXT)
- @IS_DEBUG_TRUE@@IS_GCC_TRUE@  -Wdeclaration-after-statement
- @IS_DEBUG_TRUE@@IS_GCC_TRUE@am__append_4 = -DDEBUG
- @IS_DEBUG_FALSE@@IS_GCC_TRUE@am__append_5 = -O2
--@IS_GCC4_TRUE@@IS_GCC_TRUE@am__append_6 = -iquote. -I/usr/local/include
-+@IS_GCC4_TRUE@@IS_GCC_TRUE@am__append_6 = -iquote.
- @IS_DEBUG_TRUE@@IS_GCC4_TRUE@@IS_GCC_TRUE@am__append_7 = -Wno-pointer-sign
--@IS_GCC4_FALSE@@IS_GCC_TRUE@am__append_8 = -I. -I- -I/usr/local/include
-+@IS_GCC4_FALSE@@IS_GCC_TRUE@am__append_8 = -I. -I-
- # Set flags for Solaris.
- @IS_GCC_TRUE@@IS_SUNOS_TRUE@am__append_9 = -D_XPG6 -D__EXTENSIONS__ -D_POSIX_PTHREAD_SEMANTICS