python-ply: add host compile/install
authorJeffery To <jeffery.to@gmail.com>
Fri, 27 Nov 2015 11:56:12 +0000 (19:56 +0800)
committerJeffery To <jeffery.to@gmail.com>
Fri, 27 Nov 2015 11:56:12 +0000 (19:56 +0800)
This depends on python-setuptools host install in PR #1985

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
lang/python-ply/Makefile

index ed3fb833d5a53a0fec19b418a7f5232667068a65..24f3eae95d3562e64bece8407045e347ca82344f 100644 (file)
@@ -16,13 +16,16 @@ PKG_SOURCE_URL:=http://www.dabeaz.com/ply
 PKG_MD5SUM:=94726411496c52c87c2b9429b12d5c50
 
 PKG_BUILD_DEPENDS:=python python-setuptools
+HOST_BUILD_DEPENDS:=python/host python-setuptools/host
 
 PKG_LICENSE:=BSD-3-Clause
 PKG_LICENSE_FILES:=README.md
 PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
 
+include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/package.mk
 $(call include_mk, python-package.mk)
+$(call include_mk, python-host.mk)
 
 define Package/python-ply
        SECTION:=lang
@@ -39,7 +42,7 @@ and yacc.
 endef
 
 define Build/Compile
-       $(call Build/Compile/PyMod,,install --prefix=/usr --root=$(PKG_INSTALL_DIR))
+       $(call Build/Compile/PyMod,,install --prefix="/usr" --root="$(PKG_INSTALL_DIR)")
 endef
 
 define Build/InstallDev
@@ -49,5 +52,14 @@ define Build/InstallDev
                $(1)$(PYTHON_PKG_DIR)
 endef
 
+define Host/Compile
+       $(call Build/Compile/HostPyMod,,install --prefix="" --root="$(STAGING_DIR_HOST)")
+endef
+
+define Host/Install
+endef
+
+$(eval $(call HostBuild))
+
 $(eval $(call PyPackage,python-ply))
 $(eval $(call BuildPackage,python-ply))