php5-pecl-raphf: add new package
authorMichael Heimpold <mhei@heimpold.de>
Fri, 15 May 2015 21:03:20 +0000 (23:03 +0200)
committerMichael Heimpold <mhei@heimpold.de>
Fri, 15 May 2015 21:03:20 +0000 (23:03 +0200)
Signed-off-by: Michael Heimpold <mhei@heimpold.de>
lang/php5-pecl-raphf/Makefile [new file with mode: 0644]

diff --git a/lang/php5-pecl-raphf/Makefile b/lang/php5-pecl-raphf/Makefile
new file mode 100644 (file)
index 0000000..fdd2387
--- /dev/null
@@ -0,0 +1,39 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PECL_NAME:=raphf
+PECL_LONGNAME:=Resource and persistent handles factory
+
+PKG_VERSION:=1.0.4
+PKG_RELEASE:=1
+PKG_MD5SUM:=e5e7e5c3954a5fd31c034c347f22c4a5
+
+PKG_NAME:=php5-pecl-raphf
+PKG_SOURCE:=$(PECL_NAME)-$(PKG_VERSION).tgz
+PKG_SOURCE_URL:=http://pecl.php.net/get/
+
+PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
+
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=LICENSE
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PECL_NAME)-$(PKG_VERSION)
+PKG_BUILD_PARALLEL:=1
+
+PKG_FIXUP:=autoreconf
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
+include ../php5/pecl.mk
+
+CONFIGURE_ARGS+= \
+       --enable-raphf
+
+$(eval $(call PECLPackage,$(PECL_NAME),$(PECL_LONGNAME)))
+$(eval $(call BuildPackage,$(PKG_NAME)))