[packages_10.03.2] vpzone: merge r29094
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 5 Feb 2012 16:34:04 +0000 (16:34 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 5 Feb 2012 16:34:04 +0000 (16:34 +0000)
SVN-Revision: 30278

net/vpzone/Makefile
net/vpzone/files/vpzone.init

index 2b19876898447b10a16db2e8e5073e87f90c4bbd..bcaeeaf9e56af1e8ebccc16cf3a6b046ca4e1ce9 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vpzone
 PKG_VERSION:=0.1.2
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/vpzone
index 8007ff7295a3e0e1595a3b682f1db929b50efb0f..e78a0b78776b8c2e570f69059f40cf7c44dd500a 100644 (file)
@@ -1,13 +1,15 @@
 #!/bin/sh /etc/rc.common
+# Copyright (C) 2010-2011 OpenWrt.org
 
 START=50
-DAEMON=vpzone
-PID_F=/var/run/$DAEMON.pid
+
+SERVICE_DAEMONIZE=1
+SERVICE_WRITE_PID=1
 
 start() {
-       start-stop-daemon -p $PID_F -x $DAEMON -S -b -m
+       service_start /usr/bin/vpzone
 }
 
 stop() {
-       start-stop-daemon -p $PID_F -x $DAEMON -K
+       service_stop /usr/bin/vpzone
 }