gcc/binutils: disable sysv style hash tables for generated binaries
authorFelix Fietkau <nbd@nbd.name>
Tue, 16 Aug 2022 17:35:50 +0000 (19:35 +0200)
committerFelix Fietkau <nbd@nbd.name>
Tue, 21 May 2024 15:33:23 +0000 (17:33 +0200)
GNU hash tables are always preferred by musl, so the sysv ones are completely
unused and only waste space. Reduces image size by ~1.4%

Signed-off-by: Felix Fietkau <nbd@nbd.name>
toolchain/binutils/Makefile
toolchain/build_version
toolchain/gcc/common.mk

index 8635e9710ac64e4124844a4f938aec89dca32324..d4e0c9f2db0316df9b221e593f088e584bb6f968 100644 (file)
@@ -61,6 +61,7 @@ HOST_CONFIGURE_ARGS = \
        --with-system-zlib \
        --with-zstd \
        --enable-deterministic-archives \
+       $(if $(findstring mips,$(ARCH)),,--enable-default-hash-style=gnu) \
        --enable-plugins \
        --enable-lto \
        --disable-gprofng \
index d00491fd7e5bb6fa28c517a0bb32b8b506539d4d..0cfbf08886fca9a91cb753ec8734c84fcbe52c9f 100644 (file)
@@ -1 +1 @@
-1
+2
index f5db99f869f4dbd0859b26bf30addd64e8f3029e..86a836589249b643bac2ea7bb15489010f954b54 100644 (file)
@@ -108,6 +108,7 @@ GCC_CONFIGURE:= \
                --disable-libssp \
                $(GRAPHITE_CONFIGURE) \
                --with-host-libstdcxx=-lstdc++ \
+               $(if $(findstring mips,$(ARCH)),,--with-linker-hash-style=gnu) \
                $(SOFT_FLOAT_CONFIG_OPTION) \
                $(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
                $(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 \