openldap: Add static function declaration 9607/head
authorRosen Penev <rosenp@gmail.com>
Wed, 31 Jul 2019 06:41:22 +0000 (23:41 -0700)
committerRosen Penev <rosenp@gmail.com>
Wed, 31 Jul 2019 06:43:15 +0000 (23:43 -0700)
Fixes compilation with -Werror=implicit-function-declaration .

Signed-off-by: Rosen Penev <rosenp@gmail.com>
libs/openldap/Makefile
libs/openldap/patches/800-implicit.patch [new file with mode: 0644]

index f667d76703e586cd068f68fcdaf88407a8bcf237..d7db725ce4417e1a6d5f11f1e9ecd9f7b1bf1a98 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openldap
 PKG_VERSION:=2.4.47
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=https://gpl.savoirfairelinux.net/pub/mirrors/openldap/openldap-release/ \
diff --git a/libs/openldap/patches/800-implicit.patch b/libs/openldap/patches/800-implicit.patch
new file mode 100644 (file)
index 0000000..6a39d78
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/libraries/libldap/tls2.c
++++ b/libraries/libldap/tls2.c
+@@ -41,6 +41,7 @@ static tls_impl *tls_imp = &ldap_int_tls_impl;
+ #define HAS_TLS( sb ) ber_sockbuf_ctrl( sb, LBER_SB_OPT_HAS_IO, \
+                               (void *)tls_imp->ti_sbio )
++static int ldap_pvt_tls_check_hostname( LDAP *ld, void *s, const char *name_in );
+ #endif /* HAVE_TLS */
+ #ifdef LDAP_DEVEL