lighttpd: wolfssl TLS compat module detection 14143/head
authorGlenn Strauss <gstrauss@gluelogic.com>
Sat, 5 Dec 2020 16:29:15 +0000 (11:29 -0500)
committerGlenn Strauss <gstrauss@gluelogic.com>
Sat, 5 Dec 2020 16:37:19 +0000 (11:37 -0500)
x-ref:
  "[lighttpd] -mod-wolfssl fails (requires dependency on -mod-openssl?)"
  https://github.com/openwrt/packages/issues/14139

github: closes #14139

Signed-off-by: Glenn Strauss <gstrauss@gluelogic.com>
net/lighttpd/Makefile
net/lighttpd/patches/050-wolfssl-compat.patch [new file with mode: 0644]

index 77b76c2fe19eda32c7e90384941003e6c27f19e1..55904903896e24242e4923314d08f2b7ef6b8e39 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lighttpd
 PKG_VERSION:=1.4.56
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 # release candidate ~rcX testing; remove for release
 #PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-1.4.56
 
diff --git a/net/lighttpd/patches/050-wolfssl-compat.patch b/net/lighttpd/patches/050-wolfssl-compat.patch
new file mode 100644 (file)
index 0000000..9714db2
--- /dev/null
@@ -0,0 +1,32 @@
+From a27e55b2dd0887f462c36ff788dde5c5de20a154 Mon Sep 17 00:00:00 2001
+From: Glenn Strauss <gstrauss@gluelogic.com>
+Date: Sat, 5 Dec 2020 11:19:03 -0500
+Subject: [PATCH] [core] add missing mod_wolfssl to ssl compat list
+
+add missing mod_wolfssl to ssl compat module list
+
+x-ref:
+  "[lighttpd] -mod-wolfssl fails (requires dependency on -mod-openssl?)"
+  https://github.com/openwrt/packages/issues/14139
+
+Signed-off-by: Glenn Strauss <gstrauss@gluelogic.com>
+---
+ src/configfile.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/configfile.c b/src/configfile.c
+index da444154..c7739c4f 100644
+--- a/src/configfile.c
++++ b/src/configfile.c
+@@ -345,6 +345,8 @@ static void config_compat_module_load (server *srv) {
+             append_mod_openssl = 0;
+         else if (buffer_eq_slen(m, CONST_STR_LEN("mod_openssl")))
+             append_mod_openssl = 0;
++        else if (buffer_eq_slen(m, CONST_STR_LEN("mod_wolfssl")))
++            append_mod_openssl = 0;
+         else if (buffer_eq_slen(m, CONST_STR_LEN("mod_authn_file")))
+             append_mod_authn_file = 0;
+         else if (buffer_eq_slen(m, CONST_STR_LEN("mod_authn_ldap")))
+-- 
+2.28.0
+