netdata: update to version 1.16.0 9088/head
authorJosef Schlehofer <pepe.schlehofer@gmail.com>
Sun, 21 Jul 2019 15:33:40 +0000 (17:33 +0200)
committerJosef Schlehofer <pepe.schlehofer@gmail.com>
Sun, 21 Jul 2019 15:37:56 +0000 (17:37 +0200)
- Add dependencies: libopenssl, liblz4
- Correct SPDX License Identifier
- Change URL of the website

Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
admin/netdata/Makefile
admin/netdata/patches/002-force-python3.patch

index c0471362d431543e785ce40b9ed264841d751be3..27d20987313b6f1e5a7bc16936a88d2694183455 100644 (file)
@@ -8,17 +8,17 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=netdata
-PKG_VERSION:=1.14.0
-PKG_RELEASE:=2
+PKG_VERSION:=1.16.0
+PKG_RELEASE:=1
 
 PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com>, Daniel Engberg <daniel.engberg.lists@pyret.net>
-PKG_LICENSE:=GPL-3.0+
+PKG_LICENSE:=GPL-3.0-or-later
 PKG_LICENSE_FILES:=COPYING
 PKG_CPE_ID:=cpe:/a:my-netdata:netdata
 
 PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://github.com/netdata/netdata/releases/download/v$(PKG_VERSION)
-PKG_HASH:=f3768f6927e3712dce73794c6943a12f4454410c872eb3dfd19af4f52296187a
+PKG_HASH:=d62ae89c7b9e93d40feca6edd26b77c6e27e17caa2f90a50a1a7a677f6cc8b4f
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-v$(PKG_VERSION)
 
 PKG_INSTALL:=1
@@ -30,9 +30,9 @@ include $(INCLUDE_DIR)/package.mk
 define Package/netdata
   SECTION:=admin
   CATEGORY:=Administration
-  DEPENDS:=+zlib +libuuid +libmnl
+  DEPENDS:=+zlib +libuuid +libmnl +libopenssl +liblz4
   TITLE:=Real-time performance monitoring tool
-  URL:=https://my-netdata.io/
+  URL:=https://www.netdata.cloud/
 endef
 
 define Package/netdata/description
index 84d19259da9893c582bf130acb6d1ee758e43d1b..ef2f24b064f64c851bfdd59efb16ac7f7458738a 100644 (file)
@@ -9,6 +9,6 @@
 -exec "$(command -v python || command -v python3 || command -v python2 ||
 -echo "ERROR python IS NOT AVAILABLE IN THIS SYSTEM")" "$0" "$@" # '''
 +#!/usr/bin/python3
-
  # -*- coding: utf-8 -*-
  # Description: