add fprobe
authorFelix Fietkau <nbd@openwrt.org>
Sat, 30 Apr 2005 19:52:06 +0000 (19:52 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 30 Apr 2005 19:52:06 +0000 (19:52 +0000)
SVN-Revision: 773

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/fprobe/Config.in [new file with mode: 0644]
openwrt/package/fprobe/Makefile [new file with mode: 0644]
openwrt/package/fprobe/fprobe.control [new file with mode: 0644]

index c5c798d32db517048bb5678e8c8704291f99764b..efd7937001cf86c07659b5121cd0fa8f48365748 100644 (file)
@@ -56,6 +56,7 @@ source "package/kismet/Config.in"
 source "package/nmap/Config.in"
 source "package/l2tpd/Config.in"
 source "package/tinc/Config.in"
+source "package/fprobe/Config.in"
 
 comment "Libraries"
 source "package/libpthread/Config.in"
index d071397be4b6884731c9537aa1c26e85a692e81d..99c2c7248c356b551bab199b3d6cabd9ce0ea731 100644 (file)
@@ -18,6 +18,7 @@ package-$(BR2_PACKAGE_DNSMASQ) += dnsmasq
 package-$(BR2_PACKAGE_EBTABLES) += ebtables
 package-$(BR2_PACKAGE_EZIPUPDATE) += ez-ipupdate
 package-$(BR2_PACKAGE_FPING) += fping
+package-$(BR2_PACKAGE_FPROBE) += fprobe
 package-$(BR2_PACKAGE_FUSE) += fuse
 package-$(BR2_PACKAGE_GLIB) += glib
 package-$(BR2_PACKAGE_GMP) += gmp
@@ -111,6 +112,7 @@ postgresql-compile: zlib-compile
 nmap-compile: uclibc++-compile pcre-compile libpcap-compile
 kismet-compile: uclibc++-compile libpcap-compile
 tinc-compile: zlib-compile openssl-compile lzo-compile
+fprobe-compile: libpcap-compile
 
 snort-compile: libnet-compile libpcap-compile pcre-compile
 ifeq ($(BR2_PACKAGE_SNORT_MYSQL),y)
diff --git a/openwrt/package/fprobe/Config.in b/openwrt/package/fprobe/Config.in
new file mode 100644 (file)
index 0000000..bf75c90
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_FPROBE
+       tristate "fprobe"
+       default m if CONFIG_DEVEL
+       select BR2_PACKAGE_LIBPCAP
+       select BR2_PACKAGE_LIBPTHREAD
+
+       help
+         A NetFlow probe using libpcap
+         
+         http://fprobe.sourceforge.net/
diff --git a/openwrt/package/fprobe/Makefile b/openwrt/package/fprobe/Makefile
new file mode 100644 (file)
index 0000000..ed8cf36
--- /dev/null
@@ -0,0 +1,73 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME := fprobe
+PKG_VERSION := 1.1
+PKG_RELEASE := 1
+PKG_MD5SUM := 65850d0470078269b33eee58cba77ac2
+
+PKG_SOURCE_SITE := @SF/fprobe
+PKG_SOURCE_FILE := $(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_DIR := $(PKG_NAME)-$(PKG_VERSION)
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_SOURCE_DIR)
+PKG_IPK := $(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
+PKG_CAT := bzcat
+PKG_IPK_DIR := $(PKG_BUILD_DIR)/ipkg
+
+$(DL_DIR)/$(PKG_SOURCE_FILE):
+       $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE_FILE) $(PKG_MD5SUM) $(PKG_SOURCE_SITE)
+
+$(PKG_BUILD_DIR)/.prepared: $(DL_DIR)/$(PKG_SOURCE_FILE)
+       $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE_FILE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+       touch $(PKG_BUILD_DIR)/.prepared
+
+$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
+       (cd $(PKG_BUILD_DIR) ; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               ./configure \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/bin \
+                       --sbindir=/usr/sbin \
+                       --libexecdir=/usr/lib \
+                       --datadir=/usr/share \
+                       --infodir=/usr/share/info \
+                       --mandir=/usr/share/man \
+                       --localstatedir=/var \
+                       --sysconfdir=/etc \
+                       --with-piddir=/var \
+                       --with-pcap=$(STAGING_DIR)/usr/include \
+                       --with-libpcap=$(STAGING_DIR)/usr/lib \
+                       --with-membulk=index8 \
+                       --with-hash=xor8 \
+                       $(DISABLE_NLS) \
+       )
+       touch $(PKG_BUILD_DIR)/.configured
+
+$(PKG_BUILD_DIR)/$(PKG_NAME): $(PKG_BUILD_DIR)/.configured
+       $(MAKE) -C $(PKG_BUILD_DIR)
+
+$(PKG_IPK): $(PKG_BUILD_DIR)/$(PKG_NAME)
+       $(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_IPK_DIR) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
+       mkdir -p $(PKG_IPK_DIR)/usr/bin
+       cp $(PKG_BUILD_DIR)/src/fprobe $(PKG_IPK_DIR)/usr/bin/
+       $(STRIP) $(PKG_IPK_DIR)/usr/bin/*
+       mkdir -p $(PACKAGE_DIR)
+       $(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)
+
+$(IPKG_STATE_DIR)/info/tinc.list: $(PKG_IPK)
+       $(IPKG) install $(PKG_IPK)
+
+source: $(DL_DIR)/$(PKG_SOURCE)
+prepare: $(PKG_BUILD_DIR)/.prepared
+compile: $(PKG_IPK)
+install: $(IPKG_STATE_DIR)/info/fprobe.list
+
+clean:  
+       rm -rf $(PKG_BUILD_DIR)
+       rm -f $(PKG_IPK)
diff --git a/openwrt/package/fprobe/fprobe.control b/openwrt/package/fprobe/fprobe.control
new file mode 100644 (file)
index 0000000..5028dcb
--- /dev/null
@@ -0,0 +1,9 @@
+Package: fprobe
+Priority: optional
+Section: net
+Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
+Source: buildroot internal
+Depends: libpcap, libpthread
+Description: NetFlow probe
+ libpcap-based tool that collect network traffic data
+ and emit it as NetFlow flows towards the specified collector