[packages] distribute: install host modules in hostpython search path
authorNicolas Thill <nico@openwrt.org>
Mon, 10 Oct 2011 14:21:09 +0000 (14:21 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 10 Oct 2011 14:21:09 +0000 (14:21 +0000)
SVN-Revision: 28402

lang/distribute/Makefile

index f11f6cbed9b2caa2af4982da4c384a48fc0acf22..f164508bcf3f36ee02b0659c193793ba52573302 100644 (file)
@@ -41,10 +41,10 @@ define Host/Compile
 endef
 
 define Host/Install
-       $(INSTALL_DIR) $(STAGING_DIR_HOST)$(PYTHON_PKG_DIR)
+       $(INSTALL_DIR) $(STAGING_DIR)$(PYTHON_PKG_DIR)
        $(CP) \
            $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
-           $(STAGING_DIR_HOST)$(PYTHON_PKG_DIR)
+           $(STAGING_DIR)$(PYTHON_PKG_DIR)/
 endef
 
 define Build/Compile
@@ -55,7 +55,7 @@ define Package/distribute/install
        $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
        $(CP) \
            $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
-           $(1)$(PYTHON_PKG_DIR)
+           $(1)$(PYTHON_PKG_DIR)/
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) \
            $(PKG_INSTALL_DIR)/usr/bin/easy_install \