- add lowntfs-3g variant
authorBud Dhay <bud.dhay@suisse.org>
Wed, 26 Jan 2011 13:34:27 +0000 (13:34 +0000)
committerBud Dhay <bud.dhay@suisse.org>
Wed, 26 Jan 2011 13:34:27 +0000 (13:34 +0000)
- include mount helper per default in (low)ntfs-3g packages, essentially it's only a symlink so no space wasted
- bump version to latest stable

SVN-Revision: 25113

utils/ntfs-3g/Makefile

index 71f4bf83fe75add374ce33702e4cfb351c8e83a5..092cbdebe5b39325d8bc0fbb68c2b518942c99b2 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=ntfs-3g
 PKG_RELEASE:=1
 
-PKG_VERSION:=2010.10.2
+PKG_VERSION:=2011.1.15
 
 ## 2010.3.6 needs a recent uclibc 0.9.30.2 or greater
 ## this has been fixed in 2010.5.16, keeping this in case this happens again
@@ -28,6 +28,7 @@ PKG_MD5SUM_2010.5.16:=aeff7659a4943c9223d79116f051a863
 PKG_MD5SUM_2010.5.22:=caa08c73220a7106c76f697b7a7915ec
 PKG_MD5SUM_2010.8.8:=6c109746c2708f679725a2ea441c61c6
 PKG_MD5SUM_2010.10.2:=91405690f25822142cdcb43d03e62d3f
+PKG_MD5SUM_2010.1.15:=15a5cf5752012269fa168c24191f00e2
 PKG_MD5SUM:=$(PKG_MD5SUM_$(PKG_VERSION))
 
 PKG_FIXUP:=libtool
@@ -65,6 +66,7 @@ define Package/ntfs-3g/description
   Contains:
    - ntfs-3g
    - ntfs-3g.probe
+   - mount.ntfs-3g (symlink to ntfs-3g)
 
 endef
 
@@ -80,6 +82,23 @@ config PACKAGE_NTFS-3G_USE_LIBFUSE
 
 endef
 
+define Package/ntfs-3g-low
+  $(call Package/ntfs-3g/common)
+  TITLE:=lowntfs-3g (alternative using the fuse low-level interface)
+  DEPENDS+= +ntfs-3g
+endef
+
+define Package/ntfs-3g-low/description
+  Contains:
+   - lowntfs-3g
+   - mount.lowntfs-3g (symlink to lowntfs-3g)
+
+  A driver variant using the fuse low-level interface missing some of the 
+  enhanced functionality for streams or the like. You might want to check:
+  http://www.tuxera.com/community/ntfs-3g-manual/
+
+endef
+
 define Package/ntfs-3g-utils
   $(call Package/ntfs-3g/common)
   TITLE:=ntfs-3g utilities (ntfs-3g.secaudit, ntfs-3g.usermap)
@@ -96,16 +115,6 @@ define Package/ntfs-3g-utils/description
 
 endef
 
-define Package/mount.ntfs-3g
-  $(call Package/ntfs-3g/common)
-  TITLE:=ntfs-3g mount helper
-  DEPENDS+= +ntfs-3g
-endef
-
-define Package/mount.ntfs-3g/description
-  ntfs-3g mount helper. You must enable busybox mount helper too.
-endef
-
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static
@@ -138,14 +147,11 @@ define Package/ntfs-3g/install
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ntfs-3g{,.probe} $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libntfs-3g.so.* $(1)/usr/lib/
-endef
-
-define Package/mount.ntfs-3g/install
        $(INSTALL_DIR) $(1)/sbin
        $(CP) $(PKG_INSTALL_DIR)/sbin/mount.ntfs-3g $(1)/sbin/
 endef
 
-define Package/mount.ntfs-3g/postinst
+define Package/ntfs-3g/postinst
 #!/bin/sh
 
 if [ -z "$$(grep ^\\ntfs-3g: $${IPKG_INSTROOT}/etc/filesystems)" ]; then
@@ -154,12 +160,28 @@ fi
 
 endef
 
+define Package/ntfs-3g-low/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/lowntfs-3g $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/sbin
+       $(CP) $(PKG_INSTALL_DIR)/sbin/mount.lowntfs-3g $(1)/sbin/
+endef
+
+define Package/ntfs-3g-low/postinst
+#!/bin/sh
+
+if [ -z "$$(grep ^\\lowntfs-3g: $${IPKG_INSTROOT}/etc/filesystems)" ]; then
+       echo "lowntfs-3g" >> $${IPKG_INSTROOT}/etc/filesystems
+fi
+
+endef
+
 define Package/ntfs-3g-utils/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(FIND) $(PKG_INSTALL_DIR)/usr/bin/ -type f ! -name ntfs-3g.probe ! -name ntfs-3g -exec $(INSTALL_BIN) {} $(1)/usr/bin/ \;
 endef
 
 $(eval $(call BuildPackage,ntfs-3g))
+$(eval $(call BuildPackage,ntfs-3g-low))
 $(eval $(call BuildPackage,ntfs-3g-utils))
-$(eval $(call BuildPackage,mount.ntfs-3g))