miniupnpd: bump to 2.2.2
authorStijn Tintel <stijn@linux-ipv6.be>
Thu, 13 May 2021 14:35:06 +0000 (17:35 +0300)
committerKevin Darbyshire-Bryant <6500011+ldir-EDB0@users.noreply.github.com>
Fri, 21 May 2021 17:20:37 +0000 (18:20 +0100)
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
net/miniupnpd/Makefile
net/miniupnpd/patches/301-ext_ip_reserved_ignore.patch

index f865c23b2d4be1305fd7d32911f72bc87e7ac2c0..5c02f13e52dc23ddb256d74a38b93130c2ab7a26 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=miniupnpd
-PKG_VERSION:=2.2.1
-PKG_RELEASE:=3
+PKG_VERSION:=2.2.2
+PKG_RELEASE:=1
 
 PKG_SOURCE_URL:=https://miniupnp.tuxfamily.org/files
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_HASH:=f158dc73b718ca72da69e25ef23c57c3a10a0d7e7d1b4b9b57d5690823040ec2
+PKG_HASH:=4b01c403d01c6ab140c9e4e744c89cdb66cbe25145d7a0d4566cc3fdcc0240c3
 
 PKG_MAINTAINER:=
 PKG_LICENSE:=BSD-3-Clause
index 55551eb301c54f18b6f36024f13de79504b4d210..fbff3d1ed238be7d779954393e9094da0bb5d068 100644 (file)
@@ -33,7 +33,7 @@ Date:   Sun Jul 5 10:42:52 2020 +0800
                        return 1;
 --- a/miniupnpd.c
 +++ b/miniupnpd.c
-@@ -1225,6 +1225,10 @@ init(int argc, char * * argv, struct run
+@@ -1241,6 +1241,10 @@ init(int argc, char * * argv, struct run
                        case UPNPEXT_IP:
                                use_ext_ip_addr = ary_options[i].value;
                                break;
@@ -54,7 +54,7 @@ Date:   Sun Jul 5 10:42:52 2020 +0800
 +#ext_ip_reserved_ignore=yes
  # WAN interface must have public IP address. Otherwise it is behind NAT
  # and port forwarding is impossible. In some cases WAN interface can be
- # behind unrestricted NAT 1:1 when all incoming traffic is NAT-ed and
+ # behind unrestricted full-cone NAT 1:1 when all incoming traffic is NAT-ed and
 --- a/options.c
 +++ b/options.c
 @@ -34,6 +34,7 @@ static const struct {