i2pd: add service reload support
authorR4SAS I2P <r4sas@i2pmail.org>
Mon, 7 Feb 2022 19:19:14 +0000 (19:19 +0000)
committerRosen Penev <rosenp@gmail.com>
Tue, 8 Feb 2022 05:29:08 +0000 (21:29 -0800)
Signed-off-by: R4SAS I2P <r4sas@i2pmail.org>
net/i2pd/Makefile
net/i2pd/files/i2pd.init

index f9edb00adcbce51b18eddaf5e57f1c78121cbd1f..a28adbb6142f89128e9e351339e7e3123e462eb7 100644 (file)
@@ -11,7 +11,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=i2pd
 PKG_VERSION:=2.40.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_BUILD_PARALLEL:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
index abca8824e5778bb2f379d510b74d1b85551009c1..b6a4de8a9660f027213229748ebf9222bd04ee8a 100755 (executable)
@@ -75,3 +75,7 @@ start_service() {
        config_load "i2pd"
        config_foreach start_instance "i2pd"
 }
+
+reload_service() {
+         procd_send_signal i2pd
+}