bfdd: fix compilation with glibc 14377/head
authorRosen Penev <rosenp@gmail.com>
Wed, 30 Dec 2020 23:28:49 +0000 (15:28 -0800)
committerRosen Penev <rosenp@gmail.com>
Thu, 31 Dec 2020 00:53:53 +0000 (16:53 -0800)
Remove uClibc-ng patch as it's not in the tree anymore.

Also remove the _GNU_SOURCE CFLAG for the same reason.

Refreshed patches.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
net/bfdd/Makefile
net/bfdd/patches/002-ipv6_musl_fix.patch
net/bfdd/patches/010-uclibc.patch [deleted file]

index 16b9b096bd68f603cac1d98c43a27753d888e681..fb528a681da03c22abd51d33932d3174f7968432 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bfdd
 PKG_SOURCE_DATE:=2019-08-22
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE_VERSION:=c54534beb524afc3972039f57b56ec65332b43f7
 PKG_SOURCE_URL:=https://codeload.github.com/rzalamena/bfdd/tar.gz/$(PKG_SOURCE_VERSION)?
@@ -46,8 +46,6 @@ define Package/bfdd/conffiles
 /etc/bfdd/bfdd.json
 endef
 
-TARGET_CFLAGS += -D_GNU_SOURCE
-
 define Package/bfdd/install
        $(INSTALL_DIR) \
         $(1)/usr/sbin \
index 8ee41b9309d05c66dca6b12170cb01bd38ff8223..a2f36864d7b759ae93a3e4540ce7c2feff783022 100644 (file)
@@ -1,10 +1,18 @@
---- a/bfd_packet.c     2019-08-15 02:45:47.270120616 +0300
-+++ b/bfd_packet.c     2019-08-15 02:44:38.266117706 +0300
-@@ -34,7 +34,6 @@
+--- a/bfd_packet.c
++++ b/bfd_packet.c
+@@ -29,12 +29,15 @@
+ #define _UAPI_IPV6_H
+ #endif /* _UAPI_IPV6_H */
++#include <features.h>
+ #include <linux/filter.h>
+ #include <linux/if_ether.h>
  #include <linux/if_packet.h>
  #include <linux/udp.h>
  #include <linux/ip.h>
--#include <linux/ipv6.h>
++#ifdef __GLIBC__
+ #include <linux/ipv6.h>
++#endif
  
  #include <arpa/inet.h>
  #include <sys/types.h>
diff --git a/net/bfdd/patches/010-uclibc.patch b/net/bfdd/patches/010-uclibc.patch
deleted file mode 100644 (file)
index 4c603ef..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/bfd_packet.c b/bfd_packet.c
-index e8f99f9..2c9fa91 100644
---- a/bfd_packet.c
-+++ b/bfd_packet.c
-@@ -29,6 +29,8 @@
- #define _UAPI_IPV6_H
- #endif /* _UAPI_IPV6_H */
-+#define _GNU_SOURCE
-+
- #include <linux/filter.h>
- #include <linux/if_ether.h>
- #include <linux/if_packet.h>