sipp: fix musl compatibility 76/head
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 25 Jun 2015 15:49:36 +0000 (17:49 +0200)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 25 Jun 2015 15:50:33 +0000 (17:50 +0200)
Always include `sys/types.h` as it is basically required by anything besides
Glibc and uClibc. Fixes build against musl.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
net/sipp/Makefile
net/sipp/patches/100-musl-compat.patch [new file with mode: 0644]

index 967b568e3e674d0c522f9c1f040a78f3a4d71f47..fe8e1e1002e5f9af62dfd64d86943f14774f0ce4 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2013 OpenWrt.org
+# Copyright (C) 2013-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sipp
 PKG_VERSION:=3.3.990
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/sipp
diff --git a/net/sipp/patches/100-musl-compat.patch b/net/sipp/patches/100-musl-compat.patch
new file mode 100644 (file)
index 0000000..c5e945f
--- /dev/null
@@ -0,0 +1,12 @@
+--- a/src/auth.c
++++ b/src/auth.c
+@@ -22,9 +22,7 @@
+  *           Frederique Aurouet
+  */
+-#if defined( __FreeBSD__) || defined(__DARWIN) || defined(__SUNOS)
+ #include <sys/types.h>
+-#endif
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <string.h>