Revert "ksmbd: update to 3.4.0"
authorRosen Penev <rosenp@gmail.com>
Mon, 9 Aug 2021 02:27:43 +0000 (19:27 -0700)
committerRosen Penev <rosenp@gmail.com>
Mon, 9 Aug 2021 02:27:43 +0000 (19:27 -0700)
This reverts commit 6a0ae4b19d00640fbd8fcb11a259c2d136933c96.

ksmbd 3.4.0 reworks its dependencies as a result of upstream feedback.
Unfortunately, this means that it now relies on CONFIG_FS_POSIX_ACL,
which is not easy to direcly enable in OpenWrt.

Revert in order to fix multiple build failures that people experience.

kernel/ksmbd/Makefile

index ad81567277c75105e93d9ef7cd2e8cc2d09926b9..19c32b37f729db760333924b6ed0700e67e62314 100644 (file)
@@ -1,12 +1,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ksmbd
-PKG_VERSION:=3.4.0
-PKG_RELEASE:=$(AUTORELEASE)
+PKG_VERSION:=3.3.9
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/cifsd-team/cifsd/tar.gz/$(PKG_VERSION)?
-PKG_HASH:=36fe6b8fb641c302909e65de58f0e7cff4fa641c6ad6979597fd4319d6acf775
+PKG_HASH:=c196d1773b9f89221133780fd189b550acbc56ac93c2e79260a70eab9853b3e1
 
 PKG_MAINTAINER:=Andy Walsh <andy.walsh44+github@gmail.com>
 PKG_LICENSE:=GPL-2.0-or-later
@@ -24,17 +24,20 @@ define KernelPackage/fs-ksmbd
        URL:=https://github.com/cifsd-team/cifsd
        FILES:=$(PKG_BUILD_DIR)/ksmbd.ko
        DEPENDS:= \
-               +kmod-asn1-decoder \
                +kmod-nls-base \
                +kmod-nls-utf8 \
                +kmod-crypto-md4 \
+               +kmod-crypto-md5 \
+               +kmod-crypto-hmac \
+               +kmod-crypto-arc4 \
+               +kmod-crypto-ecb \
+               +kmod-crypto-des \
                +kmod-crypto-sha256 \
                +kmod-crypto-cmac \
                +kmod-crypto-sha512 \
                +kmod-crypto-aead \
                +kmod-crypto-ccm \
                +kmod-crypto-gcm \
-               +kmod-fs-nfs-common-rpcsec \
                +kmod-lib-crc32c
 endef