backports: add -Wno-pointer-sign on <= 4.3
authorJohannes Berg <johannes.berg@intel.com>
Thu, 12 Oct 2017 09:27:55 +0000 (11:27 +0200)
committerJohannes Berg <johannes.berg@intel.com>
Thu, 12 Oct 2017 09:27:55 +0000 (11:27 +0200)
This gives annoyingly many warnings on such kernels.

Signed-off-by: Johannes Berg <johannes.berg@intel.com>
backport/Makefile.kernel

index 9f5dde0892a838186bc1a7312961ef933ffeb9b7..6c84c2d7752fc4d314145ca9ba65f68eefab5804 100644 (file)
@@ -31,6 +31,9 @@ NOSTDINC_FLAGS := \
 endif
 
 subdir-ccflags-y += $(call cc-option, -fno-pie) $(call cc-option, -no-pie)
+ifeq ($(CPTCFG_KERNEL_4_3),y)
+subdir-ccflags-y += -Wno-pointer-sign
+endif
 
 obj-y += compat/