packages/4th: forth compiler
authorGabor Juhos <juhosg@openwrt.org>
Tue, 13 Mar 2012 19:41:19 +0000 (19:41 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Tue, 13 Mar 2012 19:41:19 +0000 (19:41 +0000)
[juhosg: remove non-english comments]

Signed-off-by: Xiangfu <xiangfu.z@gmail.com>
SVN-Revision: 30929

devel/4th/Makefile [new file with mode: 0644]

diff --git a/devel/4th/Makefile b/devel/4th/Makefile
new file mode 100644 (file)
index 0000000..eaabdd6
--- /dev/null
@@ -0,0 +1,38 @@
+#
+# This is free software, licensed under the GNU General Public License v2.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=4th
+PKG_VERSION:=3.61.3
+PKG_RELEASE:=4
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-nano.tar.gz
+PKG_SOURCE_URL:=http://4th.googlecode.com/files/
+
+include $(INCLUDE_DIR)/package.mk
+define Package/4th
+       MAINTAINER:="Xiangfu Liu" <xiangfu@sharism.cc>
+       TITLE:=4th
+       SECTION:=Programming
+       CATEGORY:=prog
+       URL:=http://thebeez.home.xs4all.nl/4tH/
+endef
+PKG_BUILD_DIR:=$(BUILD_DIR)/4th-$(PKG_VERSION)
+define Package/4th/description
+4th forth compiler
+endef
+
+MAKE_VARS+=LIBRARIES="${PKG_INSTALL_DIR}/usr/lib" BINARIES="${PKG_INSTALL_DIR}/usr/bin"
+MAKE_FLAGS+=-C $(PKG_BUILD_DIR)/sources -f Makefile.NAN
+
+define Package/4th/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/sources/4th $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/sources/4tsh $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/sources/pp4th $(1)/usr/bin/
+       $(CP) $(PKG_BUILD_DIR)/sources/lib4th.a $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,4th))